Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I went from ArchLinux to Ubuntu on my dev box. I use VirtualBox to test web sites on Windows and IE. I have my Windows 7 VirtualBox image running on Ubuntu's VirtualBox. Back with ArchLinux, internet worked "out of the box" on the Windows boxes. I left the default options on the box's Network Options (NAT).

The Windows machine shows as "connected to ethernet" but reports:

The dns server isn't responding

So I can't access Internet from there. I tried searching for Ubuntu's official docs but they seem pretty outdated. I tried using my old boxes from Arch (which boot normally but have no internet) and creating a new box from Ubuntu itself, but still get the same results.

Update: I'm using VirtualBox 4.1.18 from Ubuntu's repository (apt-get install virtualbox).

share|improve this question
1  
Does your Windows client get all network configuration by DHCP? Make sure you've set that correctly in the interface configuration. Secondly, what version of VirtualBox did you install? regular from virtualbox.org or -ose from Ubuntu repositories? –  gertvdijk Dec 4 '12 at 16:42
    
Apparently yes, the Windows machine is configured to get all network configurations from DHCP. –  Fernando Briano Dec 4 '12 at 16:53
    
Can you reach the address as being the DNS server? (e.g. ping 192.168.123.1) –  gertvdijk Dec 4 '12 at 16:56
    
How do I know what the IP for the DNS should be? –  Fernando Briano Dec 4 '12 at 17:15
    
You get it via DHCP... so, just check the details on the interface. –  gertvdijk Dec 4 '12 at 19:42
add comment

1 Answer 1

up vote 5 down vote accepted

This is a known bug, either:

  • Upgrade Virtualbox at least to 4.2.2 (the better way to do it is adding the official repository, see here under Debian based distributions)
  • Configure dns by hand inside the virtual machine (you can use 8.8.8.8, Google, open dns, or your ISPs server as your virtual machine dns server).
share|improve this answer
    
Thanks! I upgraded to 4.2.2 from the official repo and it's working fine now. –  Fernando Briano Dec 7 '12 at 14:35
    
There is no 4.2.2, I can only see 4.2.12 virtualbox.org/wiki/Linux_Downloads –  Rahul Prasad May 21 '13 at 10:34
    
Please note that I said at least, 4.2.12 will be fine ;). –  Javier Rivera May 21 '13 at 15:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.