Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.04 LTS on Lenovo B560. Core Linux 3.2.0-34-generic-pae

I have set Wifi switcher "on" and Driver Broadcom STA "on".

Window "Network" --> "Aviaflight mode" isn't switched off. I added "blacklist acer_wmi" in /etc/modprobe.d/blacklist.conf.

WiFi doesn't work. (rfkill list: Hard blocked: yes).

How to switch off "Aviaflight mode" in Terminal?

share|improve this question

1 Answer 1

What is the position of switch #1 here? Does Fn+F5 change anything? What is the entirety of:

rfkill list all

enter image description here

share|improve this answer
    
rfkill list: 0: ideapad_wlan: Wireless LAN Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: yes switch #1 - "on". Fn+F5 - no reaction. The problem appeared after updating (only official 12.04). Problem options: new kernel 3.2.0-34 (?) or the mode of air flights (is always included and blocks wireless). –  Lucis Dec 4 '12 at 16:44
    
Does the problem disappear if you interrupt the boot process at the GRUB prompt and boot into an earlier kernel? Was acer-wmi loaded when you first installed? Did blacklisting it help in earlier kernels? I believe 'flight mode' is immovable if the wireless radio is hard-blocked by the hardware switch or at least if the operating system thinks it is. –  chili555 Dec 4 '12 at 21:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.