Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a new Ubuntu user, I had enough problems with Windows always crashing.

So yesterday I installed Ubuntu 12.04 on my laptop.

I have an Acer Aspire 5942g, everything is running smoothly except I cannot get the wireless to work at all. The terminal stuff is new to me, I'd appreciate any suggestions.

Obs.: I have looked at some forums/posts on the wireless issue, however none have resolved mine.

Hope you guys can help me. Thanks.

share|improve this question
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro Dec 4 '12 at 17:56

2 Answers 2

Ubuntu normally allow you to easily connect to wireless networks by just clicking the name of the network you'd like to use, but most wifi cards need a proprietary driver to work. So check on the top bar if you have a notification to install additional drivers or go to the "System Settings" > "Additional Drivers" to see if you need to install a proprietary driver for your wifi card.

If new drivers have to be downloaded, you'll need a wired connection to the internet before being able to use your wireless connection.

If no drivers is needed you will be able to see a wireless icon on you top bar of your desktop, so just click on it to see the available wifi networks around you, if you can't see your network, click on "More networks" and if your network is hidden, click on "Connect to Hidden Wireless Network..." and give the information it will ask you.

This answer is an adapted transcription of the following YouTube video: http://www.youtube.com/watch?v=NJvB97cmrWk

share|improve this answer
    
Hello, thank you for your reply. I have tried finding my wireless driver under additional drivers but it does not show. I am currently using ethernet cable for internet use which is fine, but not practical. There isn't the wireless icon at the top of my desktop unfortunately. Would you like me to enter anything in the terminal so I can show you more info about my hardware/pc? Thanks –  Joe Baldwin Dec 4 '12 at 11:25

I found when putting Ubuntu on my laptop it automatically shut off my wireless so if you have a quick button for that try pressing it. Second if you haven't tried it go to System Settings > Network > Wireless and make sure it's turned on. It should just take some online searching if that doesn't work. Make sure you've run the updates.

Just from a little search from the answers try

sudo iwconfig

That will tell you the status of your wired and wireless connections.

I also found this http://ubuntuforums.org/showthread.php?t=2035902&page=3 It's solved. Just make sure it applies to you and that you understand what each step is doing.

share|improve this answer
    
Hey, here's a copy of what I got from the terminal...joe@joe-Aspire-5942:~$ sudo iwconfig [sudo] password for joe: lo no wireless extensions. eth0 no wireless extensions. joe@joe-Aspire-5942:~$ –  Joe Baldwin Dec 4 '12 at 14:19
    
Please run lspci -nn and post the wireless card details. –  chili555 Dec 4 '12 at 14:20
    
Here's all i could fine: it doesn't even come up with anything relating to wireless.... :( 2:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe [14e4:1692] (rev 01) –  Joe Baldwin Dec 4 '12 at 15:00
    
I can tell you that from the acer website, I know which Broadcom wireless lan card it is. It's the one right at the bottom - support.acer.com/product/default.aspx?modelId=1883 I know you can't install the drivers like that, it's only compatible with Windows. I hope this can help... :) –  Joe Baldwin Dec 4 '12 at 15:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.