Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to change the pulseaudio config file as outlined on this page:

http://www.linuxplanet.com/linuxplanet/tutorials/7130/2

But if I try to do it from the command line or from going directly to the folder I get permission denied messages. I tried to chmod it, but that doesn't work either.

I guess I have to log in as root, but there are all sorts of warnings on the net that warn ignoramuses like me not to operate from root because you might destroy the system.

Is there any other way?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The "official" way to stop autospawning pulseaudio sound server is outlined in this guide from the audio developer team:

Any other method is discouraged as it may seriously break your audio system.

In short you will have to edit the following line in your /etc/pulse/client.conf to:

autospawn = no

You need to edit this file as root.

Changes will take effect after restarting the pulseaudio server with the following command:

pulseaudio -k

Please do backup all files before you edit them to be able to restore settings in case something goes wrong.

share|improve this answer
    
I followed the instructions on the Wiki page above and it worked for two days. But now, even though I have autospawn = no the dang thing keeps coming up after I kill it –  Paul Dec 6 '12 at 13:19
    
Update: The wiki in the answer above has a gksudo killall pulseaudio command that works reliably. I use it almost daily now with good results. –  Paul Dec 23 '12 at 3:21

First of all, yes, you have to log in as root temporary to edit config files. Just don't touch what you don't understand and remember all your changes. If file belongs to root, you must log in as root to chmod it. sudo nano /etc/default/pulse.pa or what you are editing. Don't run GUI applications as root unless they ask you to.

Second, don't meddle with ubuntu using old or non-ubuntu guides. Modern Ubuntu have strayed too far from "reference Linux".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.