Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Thinkpad X230. After a boot it hangs with checking battery state [OK]. A second boot is most times successful.

What I have seen in other posts doesn't fit to my problem, because

  • My graphics card is Intel 3rd Gen Core processor Graphics controller (not nvidia)
  • It happens not always
  • I have a fresh installed 12.10 with the latest updates (no upgrade)

Does anyone experience the same issues or has a solution?

share|improve this question
    
The other answer, which has a link to this site could only a temporary solution Is there a real solution? My Laptop with INTEL HD4000 graphics hang up with this error message every time I boot it. –  user140540 Mar 15 '13 at 13:52
add comment

2 Answers 2

up vote 5 down vote accepted

At least one other person had the same problem and found a solution:

http://dbastreet.com/blog/?p=972

share|improve this answer
add comment

If Xorg.1.log near the end has these lines:

[     3.404] (II) UnloadModule: "intel"    
[     3.404] (II) Unloading intel
[     3.404] (EE) Screen(s) found, but none have a usable configuration.
[     3.404] 
Fatal server error:
[     3.404] no screens found

This worked for me. It seems lightdm is way too light. You gotta slow this baby down by adding a sleep step to it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.