Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

There is an issue, for every package that I try to install.
I am using VMWare Player 3.16 & I have installed Ubuntu 12.04.

The error is:

E:Unable to locate package (PACKAGE NAME)

Also, another problem is that there are some configuration errors. So I have to use the CLI rather than the GUI. Now if this is a network error, I'm not sure as to how to open the setting from the command prompt. Even if I get to the GUI, it might not work, as the shortcuts are not available.

share|improve this question

closed as not a real question by Eliah Kagan, RolandiXor, Ringtail, fossfreedom Dec 29 '12 at 7:12

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Please edit your question and post it without ALL CAPS. –  Nanne Dec 4 '12 at 6:41
Can you please post the entire output, including the command you entered? –  Chris Wilson Dec 4 '12 at 15:36
@chris - m not sure as i am unable to find a link to attach a screenshot here. Ive tried to provide all the required details... ill try to summarize dem again... please lemme knw if i have a way to attach a screenshot. Now - i first always try " apt-get update" but it shows could not fetch from the different sites..... –  SAMEER Dec 5 '12 at 6:18
next - I try to install the applications using apt-get install package name It shows the error E:Unable to locate package package name I do not use sudo as i am already logged in as root –  SAMEER Dec 5 '12 at 6:20
Another issue which might be related is that i m able to ping the various websites from the cmd prompt with 0% packet loss......... But when i use startx to get to the GUI and try to use firefox it shows SERVER NOT FOUND........ Thanx for ur time...... Hope u'd help me find a solution :) –  SAMEER Dec 5 '12 at 6:28

2 Answers 2

sudo apt-get update first then try to install your package

share|improve this answer
W:Failed to fetch –  SAMEER Dec 4 '12 at 6:45
failed to fetch us.archive.... failed to fetch some index files failed to download. they have been ignored , or old ones are used instead... it seems like a network issue.... –  SAMEER Dec 4 '12 at 6:47
The reason that i think it is a network issue is that i am able to ping google .com and the packet loss is 0% but when i try to open a website on firefox it says server not found... –  SAMEER Dec 4 '12 at 7:05
@SAMEER, you say you are using CLI, then how are you accessing Firefox? –  saji89 Dec 4 '12 at 7:12
hi SAJI89.... i opened up the GUI using startx and then tried the firefox.. –  SAMEER Dec 4 '12 at 11:40

Try to reload everything with this :

sudo rm -rfv /var/lib/apt/lists/*
sudo apt-get update
share|improve this answer
@Air-dex..... I tried but this didnt work .. d errors havent changed...:( –  SAMEER Dec 5 '12 at 6:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.