Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having some issues installing Ubuntu Server on my mac mini 6,1. It does boot on the USB stick, install run smoothly but then after I have a 'No Operating System Found' message when i try to boot.

I've tried with & without EFI boot partition, setting it as bootable or not. I'm starting to be out of ideas to make it work.

I'd like to install it as the only system.


share|improve this question

Try booting the Live USB again, then open a Terminal and type sudo grub-install /dev/sda, then reboot.
If you can get the Ubuntu server to boot, then immediately type sudo update-grub.

(AFAIK, the sudo is unnecessary, as the Live CD/USB's Terminal is Root, but it never hurts to be safe.)

If that doesn't work, you may end up having to do a reinstall. :(
(If it makes you feel any better, I reinstalled my Ubuntu 3 times in less than a week once...)

share|improve this answer
Thanks for your help. I've tried it but still the same problem... I'm at my 15th time installing ubuntu server at least... :S – Hugo CUVILLIER Dec 4 '12 at 10:26
The message is missing operating system actually, but doesnt change anything – Hugo CUVILLIER Dec 4 '12 at 10:54
Okay, so the installation is finished, and the problem occurs when you try to boot Ubuntu? I hate to say this, but... You may have had a slight Internet glitch while downloading. Check the md5Sum of your downloaded file, and compare it with what it should be. If you don't know how to do this, see this. It explains it fairly well. – JamesTheAwesomeDude Dec 4 '12 at 14:34
Nope, the hash seems to be good. I've tried server version & desktop & I have the same problem with both of them... :S – Hugo CUVILLIER Dec 5 '12 at 5:36
btw, I've tried as well recreating the partition table as msdos (because i dont want dual boot) and installing ubuntu after, it still doest work (i get the grey screen with an exclamation mark meaning no system found)... – Hugo CUVILLIER Dec 5 '12 at 5:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.