Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I manually installed the tar.gz of openmpi 1.6.3 on Ubuntu 12.10. But now mpif90.openmpi returns the following:

 Cannot open configuration file /usr/local/share/openmpi/
                                mpif90.openmpi-wrapper- data.txt
 Error parsing data file mpif90.openmpi: Not found

How can I get mpif90.openmpi get running again? It was running fine if I install openmpi using apt-get install. But that way I will get only version 1.6.1. Thanks.

share|improve this question
    
Any reason for 1.6.3 and 1.6.1 is not sufficient? You could try installing the three .deb packages from Raring here providing 1.6.3. A quick look on the dependencies seems like it will be of no issue installing it in Quantal. –  gertvdijk Dec 4 '12 at 11:11
    
@gertvdijk Ok, thanks. I will give it a try. –  tiki Dec 4 '12 at 15:57
    
@gertvdijk It worked. Thanks! –  tiki Dec 4 '12 at 17:17
add comment

1 Answer

up vote 1 down vote accepted

Yes, already posted in the comments as a verified solution, but posting as an answer anyway.

If the version 1.6.1 from the Ubuntu repositories in 12.10 is not sufficient, you could try installing the 1.6.3 version from Raring (unreleased 13.04 development branch) here:

Download the right .debs according to your architechture and install them like

sudo dpkg -i openmpi1.6-bin_1.6.3-3_amd64.deb libopenmpi1....

A quick look at the dependencies shows this should work in the 12.10 release as well. This is not a general valid solution, as it's quite a hackish way of backporting.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.