Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Please help! I am pretty "newb" to linux and have no idea what to do. I got the message "your system must reboot to complete updates" (or similar). After rebooting I am greeted with a giant login screen and my 2nd monitor isn't showing anymore.

After logging in, I can only see a part of my desktop -- one giant folder icon. I can right click on the desktop but gives me no option to change resolution or anything.

Any help would be wonderful.

PS: I am able to get a terminal window open. Luckily that ONE folder had a terminal shortcut I had put there. So if this can help troubleshoot, please advise.

EDIT 2: This got me back to Unity working and a nice resolution and both monitors:

 apt-get purge nvidia-current
 rm /etc/X11/xorg.conf
 reboot now

Unfortunately, now I guess I don't have any HW accel for my graphics card? :(

share|improve this question
Do you have a laptop? Does it have nvidia optimus? – Vítor Manfredini Dec 3 '12 at 20:27
No, it is a desktop. It is ASUS nVidia EN9600GT graphics card. – aikeru Dec 3 '12 at 20:28
Do you have access to the screenshot utility? If not you can invoke it from the terminal with gnome-screenshot. It would be useful to see what your desktop looks like. – Chris Wilson Dec 3 '12 at 21:17
Not much to see. Basically if you zoomed in on the desktop background and had one giant-size folder icon. Pretty sure it was in 640x480 resolution. Unity wouldn't come up and compiz would crash. – aikeru Dec 3 '12 at 21:24

I had a similar problem when I tried to remove my nVidia drivers.

You need to re-install ubuntu-desktop to get your normal screen back.

Refer here for complete information : How can I uninstall a nvidia driver completely ?

share|improve this answer
+1 for the help, even though I did not use this to get it fixed, still useful. – aikeru Dec 4 '12 at 15:07

You could also check out xrandr.

With no option gives you a list of available defaults.

Update with i.e.:

xrandr --output HDMI-0 --mode 1920x1080

share|improve this answer
up vote 1 down vote accepted

Epilogue: Since it all seems to be working now, I should share what I did. Probably not the best way, but since I'm a newb I just went with what I can find. :)

  1. Downloaded latest driver for 64bit / Linux from nVidia site
  2. Download and install linux-headers-3.5.0-19-generic
  3. Open terminal, change directory to where the .run from nvidia is downloaded
  4. In terminal chmod +x ... the nvidia .run file
  5. Reboot into recovery and login to recovery terminal
  6. Run this command so nVidia script can write to stuff sudo mount -o remount,rw /
  7. Run the nVidia script itself sudo sh ./NVIDIA-...
  8. Ignore the first "... script failed..." error. Select option to allow it to blacklist, mostly "yes", "agree", etc.

I think that's everything. I didn't think of this, but had I not had the shortcut on my desktop to get to terminal, I could have just rebooted into recovery mode to get the terminal and while googling found a hotkey to get there too (CTRL + ALT + F1?).

After this everything seems to be working. I used sudo nvidia-settings from terminal to rearrange the physical location of my monitors properly.

EDIT: This happened again after I updated my system...

I ran this command that I found here:

sudo apt-get install linux-headers-`uname -r`

...and then basically repeated the entire process.

share|improve this answer

I am using Ubuntu under Oracle VirtualBox and same thing happened to me. Also I lost the mouse scroll abilites, etc.

What I did to fix the issue was re-installing the Guest Additions and all the functionality came back.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.