Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Issuing lspci -vnn gave me this (relevant) output:

08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n
[14e4:4365] (rev 01)

I don't know how to proceed in order to get it working. Help on this is appreciated.

share|improve this question
1  
Are you sure it is BCM43142 and not BCM4312 ? –  To Do Dec 3 '12 at 16:00
    
Please check here: askubuntu.com/questions/215890/… –  chili555 Dec 3 '12 at 16:01
    
i tried installing Broadcom Corporation BCM43142 from software center but dint fix at all –  Sonjay Singh Dec 31 '12 at 10:41

2 Answers 2

$ lspci -vvnn | grep 14e4
08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

download this file: http://jas.gemnetworks.com/debian/pool/main/w/wireless-bcm43142/wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb

sudo apt-get install linux-headers-generic build-essential dkms

navigate to the folder you have saved the downloaded file and run this command.

sudo dpkg -i wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb

i tried this but i was to fix : lo no extension

share|improve this answer
    
Please, edit your own question if you want to add more details. –  Andrea Corbellini Jan 29 '13 at 15:06

This is how I solved the problem in my Dell Inspiron 5520 laptop. Once you have the dkms mentioned above you need to download and install BroAdcom STA. There are two ways of doing this

  1. Search for Brodcom STA driver in http://pkgs.org and use dpkg command to install
  2. The best way is to connect to ethernet and from your additional drivers list enable Brodcom STA wireless driver
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.