Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having problem with wifi network that have multiple access points. ubuntu keeps roaming between access points because of high sensitivity. Based on reading the manual for iwconfig, there is an option to set sensitivity like iwconfig wlan0 sens -80. This keeps failing with operation not permitted. So I want to know if there is a way, to set the sensitivity of roaming in Ubuntu.

share|improve this question

1 Answer 1

I think the better way to approach that problem is to run:

nm-tool

Find the MAC address for the access point you want with the highest signal strength. Then Edit Connections in Network manager to tell NM that is the MAC, also known as BSSID, you want. Please see attached. It should then stay on that MAC and not roam to others.enter image description here

share|improve this answer
    
Hmm, how can I figure out which access point is best. The problem is on mac it does not have a problem. Only ubuntu, fyi, I am running dual boot on macbook pro. –  Ali Dec 3 '12 at 18:26
    
Open a terminal and run the command: nm-tool. At the end, there will be a list of wireless access points listing the strength and MAC address among other details. Pick the network you prefer, and select the specific listing with the best strength. Put its MAC address in 'BSSID' as above. –  chili555 Dec 3 '12 at 18:44
    
Oh, sorry I did not realize it lists all access points. I will give it a try and report back. But just in case, is there a way to change the sens parameter? Thanks. –  Ali Dec 3 '12 at 20:26
    
After some tests, it seems ubuntu refuses to connect to the access point with highest signal that brodcast on channel 11. I installed wicd and tried through the gui after stoping network manager and I confirm that ubuntu refuses to connect to the access point on channel 11. Possibly related to this –  Ali Dec 3 '12 at 21:16
    
Is that your wireless card as listed in lspci -nn? 14e4:4727? I doubt you are using the same driver. wl is preferred. On some cards, sens is not adjustable. Check: iwlist wlan0 event. If your wireless interface is eth1, then iwlist eth1 event. –  chili555 Dec 3 '12 at 21:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.