Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am presently experiencing random disconnections from my wireless network. It looks like it is becoming more and more frequent (however I have not seen any clear pattern). This is killing me... Basically at some point the wifi network stops being detected and i CANNOT SEE ANY NETWORK ANYMORE like if the network card was shut down

Below is some information that should help as well as one attempt to fix it (from Ubuntu forums).

Machine: Acer Aspire S3 (exact model no. Aspire S3-951-2464G34iss)

statquant@euclide:~$ lsb_release -d
Description:    Ubuntu 12.04.1 LTS

statquant@euclide:~$ uname -mr
3.2.0-33-generic x86_64

statquant@euclide:~$ sudo /etc/init.d/networking restart
* Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
* Reconfiguring network interfaces...

statquant@euclide:~$ lspci
02:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)

statquant@euclide:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 004: ID 064e:c321 Suyin Corp. 
Bus 002 Device 003: ID 0bda:0129 Realtek Semiconductor Corp.

statquant@euclide:~$ ifconfig
wlan0     Link encap:Ethernet  HWaddr 74:de:2b:dd:c4:78  
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::76de:2bff:fedd:c478/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:913 errors:0 dropped:0 overruns:0 frame:0
          TX packets:802 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:873218 (873.2 KB)  TX bytes:125826 (125.8 KB)

statquant@euclide:~$ iwconfig
wlan0     IEEE 802.11bgn  ESSID:"Bbox-D646D1"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:19:70:80:01:6C   
          Bit Rate=65 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=56/70  Signal level=-54 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:71   Missed beacon:0

statquant@euclide:~$ dmesg | grep "wlan"
[   17.495866] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   17.498950] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   20.072015] wlan0: authenticate with 00:19:70:80:01:6c (try 1)
[   20.269853] wlan0: authenticate with 00:19:70:80:01:6c (try 2)
[   20.272386] wlan0: authenticated
[   20.298682] wlan0: associate with 00:19:70:80:01:6c (try 1)
[   20.302321] wlan0: RX AssocResp from 00:19:70:80:01:6c (capab=0x431 status=0 aid=1)
[   20.302325] wlan0: associated
[   20.307307] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   30.402292] wlan0: no IPv6 routers present

statquant@euclide:~$ sudo lshw -C network
[sudo] password for statquant: 
*-network               
   description: Wireless interface
   product: AR9485 Wireless Network Adapter
   vendor: Atheros Communications Inc.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlan0
   version: 01
   serial: 74:de:2b:dd:c4:78
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=3.2.0-33-generic firmware=N/A ip=192.168.1.3 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:17 memory:c0400000-c047ffff memory:afb00000-afb0ffff

statquant@euclide:~$ iwlist scan
wlan0     Scan completed :
      Cell 01 - Address: 00:19:70:80:01:6C
                Channel:6
                Frequency:2.437 GHz (Channel 6)
                Quality=56/70  Signal level=-54 dBm  
                Encryption key:on
                ESSID:"Bbox-D646D1"
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                          9 Mb/s; 12 Mb/s; 18 Mb/s
                Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                Mode:Master
                Extra:tsf=000000125fb152bb
                Extra: Last beacon: 40020ms ago
                IE: Unknown: 000B42626F782D443634364431
                IE: Unknown: 010882848B960C121824
                IE: Unknown: 030106
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : CCMP TKIP
                    Authentication Suites (1) : PSK
                IE: WPA Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : CCMP TKIP
                    Authentication Suites (1) : PSK
                IE: Unknown: 2A0100
                IE: Unknown: 32043048606C
                IE: Unknown: DD180050F2020101820003A4000027A4000042435E0062322F00
                IE: Unknown: 2D1A4C101BFF00000000000000000000000000000000000000000000
                IE: Unknown: 3D1606080800000000000000000000000000000000000000
                IE: Unknown: DD0900037F01010000FF7F
                IE: Unknown: DD0A00037F04010000000000

I did the following (after looking for fixes of similar problems), but unfortunately this fails to fix my issue.

sudo modprobe -r iwlwifi 
sudo modprobe iwlwifi 11n_disable=1

This is a snapshot I obtained via iwscanner, as you can see even when the wifi is working there is small losses scan


I did this following the following this thread, worked well for a few hour but I got a disconnection :( Here is what I did:

statquant@euclide:~$ sudo modprobe -rfv ath9k
[sudo] password for statquant: 
rmmod /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
rmmod /lib/modules/3.2.0-34-generic/kernel/net/mac80211/mac80211.ko
rmmod /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko
rmmod /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
rmmod /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless/ath/ath.ko
rmmod /lib/modules/3.2.0-34-generic/kernel/net/wireless/cfg80211.ko

statquant@euclide:~$ sudo modprobe -v ath9k nohwcrypt=1
insmod /lib/modules/3.2.0-34-generic/kernel/net/wireless/cfg80211.ko 
insmod /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless/ath/ath.ko 
insmod /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko 
insmod /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko 
insmod /lib/modules/3.2.0-34-generic/kernel/net/mac80211/mac80211.ko 
insmod /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko nohwcrypt=1
share|improve this question
    
What's your model of S3? (eg aspire 34347-5643US). This matters because this line has different cards. I noted that one of them has an Atheros AR5BWB225 card that works out of the box. –  William Jan 4 '13 at 20:16
1  
iwlwifi solutions are not what you're looking for. You don't have an Intel WiFi adapter, but an Atheros one, managed by ath9k. –  gertvdijk Jan 6 '13 at 13:11
    
Thanks for the iwscanner graph! Are other devices in your wireless network also affected by this issue? It seems that your AP is completely gone (reboot? crash? hardware fault?) for a little while. –  gertvdijk Jan 6 '13 at 18:05
    
@gertvdijk: Hey, yeah I think the big "hole" is a little bit fake. By the way I had iwscanner installed on my wife's laptop (an HP running Ubuntu 10.04), which does NOT have the problem. We also see some little stops... I am a bit lost –  statquant Jan 6 '13 at 21:39
2  
Do you have any entries in your /var/log/syslog when this happens? Another thing you could try is sudo tshark -w dump.pcap. This writes all your network traffic to that file. Maybe shortly before there is some special packet. Last option: Install dstat, start it in a console and look what happens around the disconnect. Maybe there is some suspicious system activity. –  qbi Jan 8 '13 at 22:51

3 Answers 3

up vote 0 down vote accepted
+100

As mentions in here: http://ubuntuforums.org/showthread.php?t=2018238

There is a easy way to fix your problem

Try these command

sudo modprobe -rfv ath9k
sudo modprobe -v ath9k nohwcrypt=1

If it work, make it permanent by add these line to /etc/rc.local

Or create (or edit) /etc/modprobe.d/ath9k.conf by this command

gksudo gedit /etc/modprobe.d/ath9k.conf

and add this to /etc/modprobe.d/ath9k.conf

options ath9k nohwcrypt=1

share|improve this answer
    
Ok I tried... It was promissing but I got a disconnection after a few hours :(. As usual when it happen I CANNOT find any wifi network so my only solution is to reboot –  statquant Jan 6 '13 at 17:46
    
OK what I did was that I made the changes permanent as noted, if executing the command lines did not fix, the permanent file solution seem to have fixed it. THANKS –  statquant Jan 10 '13 at 8:16
    
You are welcome –  Arch user Jan 10 '13 at 10:48

Here's what you can do check the frag and rts settings on your gateway. I believe the defaults are frag 2346 rts 2347 so do this command:

sudo iwconfig wlan0 
frag 2346 rts 2347

Hope this helps!

share|improve this answer

Can you try the backported 3.5.x kernel? Install it with sudo apt-get install linux-image-generic-lts-backport-quantal. It is in the repository. Maybe the new kernel has newer drivers for your card.

Off: At our dormitory a 3.0.0 -> 3.2 upgrade solved a problem like this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.