Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have duall access l2tp connection to internet through router and pptp connection to my company's local network. Network Manager connects succesfully to vpn, but when I try to get some resources from company's network(for examle, clone git repository or connect to jira's dashboard), vpn connection breaks up with message(from syslog):
short read (-1): Message too long
whereas connection to moinmoin wiki causing no errors.
Ubuntu version: 12.10

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Usually this issue happens because of high MTU(Maximum Transmission Unit) value. So the fix is to Change the MTU value in the NetworkManager.

Open System Settings -> Network

Under "Wired" select options and change the MTU to some lower value

Alternate way to change this settings is by editing the /etc/network/interfaces and add the line MTU value.

mtu some_value_here

Now restart the networking /etc/init.d/networking restart

To check the current MTU value use the command /sbin/ifconfig and look MTU in eth0

share|improve this answer
    
maybe I should check MTU in wlan0, because i'm using connecting through wifi? –  user289409 Dec 3 '12 at 8:53
    
and thank's it's help me –  user289409 Dec 3 '12 at 9:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.