Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have duall access l2tp connection to internet through router and pptp connection to my company's local network. Network Manager connects succesfully to vpn, but when I try to get some resources from company's network(for examle, clone git repository or connect to jira's dashboard), vpn connection breaks up with message(from syslog):
short read (-1): Message too long
whereas connection to moinmoin wiki causing no errors.
Ubuntu version: 12.10

share|improve this question
up vote 2 down vote accepted

Usually this issue happens because of high MTU(Maximum Transmission Unit) value. So the fix is to Change the MTU value in the NetworkManager.

Open System Settings -> Network

Under "Wired" select options and change the MTU to some lower value

Alternate way to change this settings is by editing the /etc/network/interfaces and add the line MTU value.

mtu some_value_here

Now restart the networking /etc/init.d/networking restart

To check the current MTU value use the command /sbin/ifconfig and look MTU in eth0

share|improve this answer
maybe I should check MTU in wlan0, because i'm using connecting through wifi? – user289409 Dec 3 '12 at 8:53
and thank's it's help me – user289409 Dec 3 '12 at 9:18
This worked for me. Before it was on automatic (I guess this is something around 1500). After setting it to 1000, my connection was stable. – panmari Feb 25 at 12:18
The same as @panmari. It was automatic and 1000 solved the problem. – tomrozb 2 days ago

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.