Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have added a patch to the Ubiquity source and am attempting to build and install the package to test it, however I get the following error when I execute ./configure,

checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version
0.9.0... yes checking for PANEL... yes checking for CHEESE... no configure: error: Package 
requirements (glib-2.0
        gtk+-2.0 >= 2.10.0
        gobject-2.0
        pygobject-2.0
        cheese-gtk) were not met:

No package 'cheese-gtk' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a 
non-standard prefix.

Alternatively, you may set the environment variables CHEESE_CFLAGS and CHEESE_LIBS to avoid 
the need to call pkg-config. See the pkg-config man page for more details.

This is a truncated version - there's far more that came before this, but this is where the error occurred.

I have no idea where to start with this. I tried checking man pkg-config, but that didn't really help, except I now have a vague understanding of what pkg-config is supposed to do. None of the packages listed as being missing can be found by apt-get. I got cheese (different from cheese-gtk apparently) installed, but that hasn't helped. I would really appreciate some help troubleshooting this.

share|improve this question
4  
Try installing libcheese-gtk-dev –  Jorge Castro Jan 20 '11 at 19:42
    
That worked. Thanks a lot :) –  Chris Wilson Jan 20 '11 at 19:45
add comment

2 Answers

up vote 3 down vote accepted

Install libcheese-gtk-dev, and it'll work. Also, when building from source, it's a good idea to run apt-get build-dep <package-name> before building from source a package that is also available in the repositories (including any third-party repositories you have activated). This will pull in all the packages upon which the building of the package is dependent. Thanks to Jorge Castro's comment and andrewsomething's answer for this.

share|improve this answer
add comment

As you have already found out, you needed the libcheese-gtk-dev package. In the future, you can save yourself the headache of matching pkg-config checks with Ubuntu packages by using sudo apt-get build-dep ubiquity This will install all of the build dependencies for the package.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.