Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The following message appear every time I reboot/boot my ubuntu 12.04.1

CIFS VFS: default security mechanism requested. The default security mechanism will be upgraded from nbtlm to ntlmv2 in kernel realese 3.3

I'am searching for a solution, if there is one for this message, I really don't understand it.

Following my fstab

//$/ /mnt/winshare/ cifs user,file_mode=0777,dir_mode=0777,rw,gid=1000,credentials=/root/creds 0 0

I can use my mounted folder with no problem, I just want to know why this message is appearing and if have something that I can do to fix this problem or hide this warning.


John sent a answer, saying to add the option "sec=ntlmv2", this solved him problem, but unfortunally to me when I try to mount appear "mount error(22): Invalid argument"

can anyone help me?

share|improve this question

Add sec=ntlmv2 to your line in fstab like so:

//$/ /mnt/winshare/ cifs user,file_mode=0777,dir_mode=0777,rw,gid=1000,sec=ntlmv2,credentials=/root/creds 0 0

I had the same issue for a long time, finally fixed it today.

share|improve this answer
Thanks John for sharing you fix! – André M. Faria Jan 14 '14 at 16:44
John, Just one problem, when I try to mount it returns "mount error(22): Invalid argument", have heard about this error? can help me? – André M. Faria Jan 14 '14 at 17:13
Your fstab line has "user" in it, but if you check the man page for mount.cifs you will see that this should be specified as "user=arg" (where "arg" is the username to connect as). If that doesn't resolve, try mounting the share manually with mount.cifs and use the --verbose flag to get details. – John Bigboote Aug 23 '14 at 15:08

Try to replace user option with guest. This is my /etc/fstab:

//my_laptop/public /home/user/winshare cifs guest,rw......

And this message not appears at boot.

share|improve this answer
The OP also has the option credentials=... so I don't think logging in as a guest to the share will help as he probably needs credentials. – gertvdijk Jul 26 '13 at 10:20
As "qertvdijk" said I need credentials, so I can't use guest option. – André M. Faria Jan 14 '14 at 16:42
up vote 0 down vote accepted

After googling and asking here and there, I found the answer.

I'm using "sec=ntlmssp" instead of "sec=ntlvm2"

//charles.codex/Documents/ /mnt/charles cifs user,iocharset=utf8,file_mode=0777,dir_mode=0777,rw,gid=1000,nounix,sec=ntlmssp,credentials=/root/credentials/charles 0 0

This was commented at Problem with mount using option "sec=ntlmv2"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.