Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay! This sounds kind of hard, but it should be entirely doable.

I have Ubuntu and Windows on the same disk. On the Windows partition, I have a game installed (Guild Wars 2, but this shouldn't matter). Upon booting up Ubuntu, the Windows partition is mounted under "/home/ruben/Windows". Under Windows, my game folder would be in "C:\Program Files (x86)\ArenaNet\Guild Wars 2". So under Ubuntu, it's in "/home/ruben/Windows/Program Files (x86)/ArenaNet/Guild Wars 2".

Now, because I want to save space, and because I want to be able to access the game from both Ubuntu and Windows, I want to create a path to "/home/ruben/Windows/Program Files (x86)/ArenaNet/Guild Wars 2" for PlayOnLinux. PlayOnLinux, per default, installs Guild Wars 2 in this folder:

"/home/ruben/.PlayOnLinux/wineprefix/GuildWars2/drive_c/Program Files (x86)/ArenaNet/Guild Wars 2"

So what I want to do is create a fake folder in "/home/ruben/.PlayOnLinux/wineprefix/GuildWars2/drive_c/Program Files (x86)" that redirects to "/home/ruben/Windows/Program Files (x86)/ArenaNet". Can this be done?

What I've tried doing is this:

sudo ln -s "/home/ruben/Windows/Program Files (x86)/ArenaNet" "/home/ruben/.PlayOnLinux/wineprefix/GuildWars2/drive_c/Program Files (x86)"

But it doesn't appear to work, as PlayOnLinux gives me errors about not finding the folder.

Any help would be so much appreciated.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Speak of the devil. I deleted Guild Wars 2 inside POL and ran the installation procedure of Guild Wars 2 again until it reached about 300 MB for good measure. I then deleted the ArenaNet folder POL had created, and made the symbolic link described in my question.

sudo ln -s "/home/ruben/Windows/Program Files (x86)/ArenaNet" "/home/ruben/.PlayOnLinux/wineprefix/GuildWars2/drive_c/Program Files (x86)"

And it worked! So soon after posting my question. I hope this helps anyone else, then.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.