Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought a new Lenovo IdeaPad G580 leptop. My machine is now dual booting for both Win7 and Ubuntu 12.04.1.

The issue I'm having is that I don't have internet access at all (from both wired connection and wifi connection). I saw some topics describing such issues, but all were for either a wired connection that was not working or a wifi connection that was not working. All solutions required one of them to work (so that a package could be downloaded), but in my case I don't have both.

At first, I thought that this is a hardware issue, but the wifi is working perfectly fine within Win7 (I'm dual booting, remember?). I must admit I never tested the wired connection within Win7. Of course I had to install a driver for Win7 from the disk I got with the laptop to make it work, but there is no corresponding driver for Ubuntu. I tried searching for such a driver in Lenovo's website with no results.

Can anyone help me with my issue?

Thanks in advance

Edit: Just thought it might help with resolving the issue. When saying that the wifi connection doesn't work, I wasn't accurate. Sometime (in those very rare attempts to connect to the internet), I can see my wireless hotspot on the list (and only mine. for some reason I can't see other hotspots that are present nearby). When trying to connect to it, I'm typing my password and waiting for a long time to get a pop-up asking for my password again. This is happening 3-4 times until my wireless hotspot is being removed from the list of wireless connections. Again, When booting to Win7 - no issues at all (and I can see in my hotspot-list other options too).

share|improve this question
    
Is there anyone who can help me? Please... –  Ahavat Hinam Dec 4 '12 at 4:46

1 Answer 1

up vote 0 down vote accepted

OK,

So after searching through the web and reading a lot, I found out that my laptop have a BCM4313 wireless card. This helped me be more focused on my search. There were bunch of solutions, each was working on a different computer with different spec, and it took me a while to which is good to my issue. The solution was based mostly on the answer in here. This is what I did: I went to a different computer with internet connection (actually, I was booting into Win7 since I'm dual booting, and this is why it took me more time, since I had to switch my OS all the time, just to find out that I didn't saved every link and file needed for each solution when booted to Ubuntu without the network connection :S ). I then opened a VM in there while installing Ubuntu 12.04.1 and disabling the network connection on the guest machine (this way I gained a machine with a similar state to my laptop, but with the ability to enable the network and download whatever I need to fix my issue). After installing the guest machine, I enabled the network and did the following:

$ mkdir tmp_debs
$ cd tmp_debs
$ sudo wget `apt-get --ptint-uris --yes install bcmwl-kernel-source broadcom-sta-common broadcom-sta-source`

I then copied the *.deb files to a flash-drive, booted into my Ubuntu, connected the falsh-drive and copied all *.deb files localy to a tmporary directory. Then I executed the following command:

$ sudo dpkg -i *.deb

After that I removed a module:

$ lsmod | grep "b43\|ssb\|bcma\|wl"

Since the output of this command indicated that I have only the bcma, I did the following:

$ rmmod bcma

Thant's it. I know that the link provided above showed that I had to reverse the order of things I actually did and that there are more stuff needed to be done, but I forgot to do the rest and after rebooting, my network card worked perfectly fine. Plus, I'm not sure that the rmmod bcma is really necessary, but this is what worked for me. You can try doing it without it if you want.

  • Comment: For some reason, I didn't managed getting the list of debs from all VMs. There were computers that managed to find that list and others that gave me an error as an output. For those who can't get the list (or want to make life more easy), I'm providing here the list of debs needed to be download from (any) computer with internet connection (using the wget tool). Copy the following list into a file and do wget --input-file <file_name> instead of the wget command above.

List:

http://us.archive.ubuntu.com/ubuntu/pool/main/libu/libunistring/libunistring0_0.9.3-5_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/g/gettext/libgettextpo0_0.18.1.1-5ubuntu3_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.6/libstdc++6-4.6-dev_4.6.3-1ubuntu5_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.6/g++-4.6_4.6.3-1ubuntu5_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/g/gcc-defaults/g++_4.6.3-1ubuntu5_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/libt/libtimedate-perl/libtimedate-perl_1.2000-1_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/d/dpkg/libdpkg-perl_1.16.1.2ubuntu7_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg-dev_1.16.1.2ubuntu7_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/b/build-essential/build-essential_11.5ubuntu2.1_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/d/dkms/dkms_2.2.0.3-1ubuntu3_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu6.1_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/multiverse/b/broadcom-sta/broadcom-sta-common_5.100.82.112-4_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/h/html2text/html2text_1.3.2a-15_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/g/gettext/gettext_0.18.1.1-5ubuntu3_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/i/intltool-debian/intltool-debian_0.35.0+20060710.1_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/p/po-debconf/po-debconf_1.0.16+nmu2ubuntu1_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/a/apparmor/dh-apparmor_2.7.102-0ubuntu3.7_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/d/debhelper/debhelper_9.20120115ubuntu3_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/d/diffstat/diffstat_1.54-1_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/q/quilt/quilt_0.50-2_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/multiverse/b/broadcom-sta/broadcom-sta-source_5.100.82.112-4_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/f/fakeroot/fakeroot_1.18.2-1_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/liba/libalgorithm-diff-perl/libalgorithm-diff-perl_1.19.02-2_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/liba/libalgorithm-diff-xs-perl/libalgorithm-diff-xs-perl_0.04-2build2_i386.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/liba/libalgorithm-merge-perl/libalgorithm-merge-perl_0.08-2_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/libs/libsys-hostname-long-perl/libsys-hostname-long-perl_1.4-2_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/main/libm/libmail-sendmail-perl/libmail-sendmail-perl_0.79.16-1_all.deb
http://us.archive.ubuntu.com/ubuntu/pool/universe/m/module-assistant/module-assistant_0.11.4_all.deb

Hope this can help someone :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.