Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an old speedtouch usb modem (revision 0) and on my desktop with xubuntu 12.04 I've configured a pppoe connection. I can connect and my ISP assign an IP address and the DNS but the primary DNS address is not reachable by ping, the secondary yes but no address is resolved then I can't surf the web. Then I want to set the open DNS but there is bo way, if I change manually /etc/resolv.conf it is rewrited by some script (there is the flag usepeerdns on the configuration script, if I exclude it there is no way to assign any DNS server because resolv.conf is not read) also if I set not writable the file changing the default permission. I changed dhclient.conf with the code

prepend domain-name-servers 208.67.222.222,208.67.220.220;

and now if I connect by a wifi connection to my router I'm using openDNS server but ppp does not use this script as long as I can see and the DNS server is always setted by my ISP. How can I use set DNS manually to a PPP connection? Is there any way to change it after the connection? Why NetworkManager is not able to manage my dsl connection, it seems not able to manage the dsl usb cable modem. If I use pppoeconf NetworkManager doesn't start and I have to manually delete the lines added to /etc/network/interfaces because the system is not able to start with full configuration of network If I connect a modem-router to the same line I can surf with the DNS server assigned by my ISP, I can't figure why. Some suggestion? Thanks to all


The problem is that NetworkManager doesn't manage my usb adsl modem (speedtouch 330). Also if I try to set the interface in /etc/network/interfaces NetworkManager process doesn't start when I reboot the system and I have to restart it manually after large delay before the system is ready. In any case it is not the DNS supplied by my ISP the problem because if I address a query to the DNS server expliciting its address it answer the query, if I not explicit the dotted address of the DNS server the pc answers that no server is reachable. The file /etc/resolv.conf is a symlink to /etc/ppp/resolv.conf that is updated when I connect then I don't understand because the system does not use the DNS listed in the configuration file

share|improve this question
add comment

1 Answer 1

If you are using NetworkManager then you should use the Connection Editor to adjust network settings. To set your own nameserver addresses, click on the network indicator | Edit Connections...; select your connection; open the "IPv4 Settings" tab; change "Automatic (DHCP)" to "Automatic (DHCP) addresses only"; enter the desired nameserver addresses in the "Additional DNS servers" field.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.