Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

New to Ubuntu. During installation, the computer identified the wifi card and asked me to connect to the network. I did. After the first restart the wifi was working and I could see networks and connect to them. After the second restart the wireless has VANISHED. Still, the Broadcom STA drivers are enabled in system settings/additional drivers. Tried to restart 5 more times- no effect. I have studied very many topics on askubuntu but none of them work.

share|improve this question
    
Which options have you actually found and tried? What does ifconfig -a show? What does lspci -nn show? etc. –  gertvdijk Dec 4 '12 at 14:01

1 Answer 1

I am also using BCM4313 on 12.10, but on IdeaPad. There are couple possible issues, so lets start with:

BCM4313 is not a great wifi card and linux support is also not perfect. However, it is fine for day to day use and you can get it running on linux without much work.

In my case I have installed a module for the wifi using following command:

sudo apt-get install build-essential linux-headers-generic bcmwl-kernel-source

If you can see other WIFI networks, but not your one it might be because BCM4313 doesn't support high radio channels. In my case, I had to adjust my router from channel 13 to channel 8 to get it working fine.

Hope it helps.

share|improve this answer
    
I have an error while installing bcmwl-kernel-source: –  Denis Dec 2 '12 at 12:14
    
wl module does not exist –  Denis Dec 2 '12 at 12:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.