Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I m using WD my passport hard drive in windows 7 . It is password protected which i am able to open in any windows OS but i am unable to unlock and mount the HDD in ubuntu 12.10. How can i access my HDD on Ubuntu 12.10 ?

share|improve this question

Western Digital use a proprietary hardware method to supposedly achieve FDE (Full disk encryption) although it actually appears to be just a blocker, not encryption. It doesn't conform to the specification for FDE.

There's no Linux solution to this since Western Digital will not provide one. There are reports of people being able to unlock the drive however, buy installing Windows in a VM, unlocking the drive, then disconnect the drive from the VM. Linux/Ubuntu will then be able to access it for that session.

Most people seem to be recommending that the password protection be turned off after which the drive can be used normally. According to reports the drive does not need to be unencrypted, and there is no further trouble accessing the drive. eg Ubuntu Forums

share|improve this answer

I just went to a computer with Windows, hooked up my passport, installed wd security on that computer, ran it, and turned off the password on my Passport. Since then, I have been able to use it with ubuntu with no problems.

share|improve this answer

First a correction: although it actually appears to be just a blocker, not encryption. It is quite unlikely to be just a blocker. See on how such encryption can be implemented.

Now for you answer, you can do any of the following:

  • Use a VM as explained in other answers
  • Do not use encryption (obvious :P )
  • Use some 3rd-party open-source software like KenMacD's wdpassport-utils.

Of course you should be cautious with the last choice, but you can always do some testing prior to regular usage. Needless to say, you should always have data you care about in at least in two copies.

share|improve this answer

My solution

  1. Start the WD software under Windows (Win7 on my system)

  2. Under Drive settings -> Security, I disabled the drive.

It now appears like a plain empty drive around 950GB in size.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.