Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having trouble with Ubuntu 12.10. Everything is working fine, although there is a slight problem. It seems to lag every once in a while, as in I will move the mouse, then about two seconds later the cursor will actually move on the screen. Is there any way to fix this? This is my first day using Ubuntu and I put it on a computer I built myself. I don't have much experience so a detailed answer would be very much appreciated.

share|improve this question
up vote 0 down vote accepted

I have the same symptom. did you install any display drivers? my solution is to remove the compiz or disable composite,but without that you can not enable desktop effects.

solution 1:

 sudo apt-get remove composite

solution 2:

=====remember to backup the original files!!!!!!!!!!!!!!!!!=====

sudo gedit /etc/X11/xorg.conf

then add:

Section "Extensions"         
    Option  "Composite" "Disable"


my laptop is using nVidia G102M,and with the method mentioned above i solved the problem. my classmate told me that the problem may be caused by nVidia drivers (i'm not using open-source drivers)

I hope this can help you

(my english is poor)

share|improve this answer
Hello. Your english is not poor at all! It is actually quite good. If I remove just the compiz will I still be able to enable desktop effects? – Nick M Dec 3 '12 at 22:01
If you remove the compiz,the desktop effects will not work,but if you disable composite only(with the solution 2),other desktop effects may still work. REMEMBER TO BACKUP THE ORIGINAL FILES!!!! – Gordon.Freeman Dec 4 '12 at 6:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.