Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before downvote, please this is not a duplicate I read the related questions and couldn't solve my problem.

I bought a new laptop that originally had Win8 installed, I formatted it, installed Windows 7 and then went to install Ubuntu.
That didn't work because no Ubuntu version whatsoever (10.04, 11.04 or 12.04) were able to even detect partitions on my harddisk.

So I decided to go the other way, install Ubuntu then try installing Windows and fix grup after it gets broken due to Installing Windows.
Using GParted, I created an NTFS partition and then rebooted and tried installing Windows 7. That failed, the error message was speaking about GPT table.

I am trying to just understand what's going on here, why am I unable to do what I was perfectly doing on my old machine(please in enough detail; let me know if I need to provide more information)? and how can I fix this?

I am trying to avoid using Wubi so if there's any other way, I'd take it.
Currently running on Ubuntu if I need to use some tool to extract more information about my HDD

EDIT:
Thanks, fabricator4.
I indeed used gparted to delete my partioning table and MSDOS table worked just fine(my HDD's size is 500 GBs only).
I did consider installing 12.04, the thing works just fine on live CD and when I ran the installer it recognized Windows partitions and all; I made a partition for it and installed.
Once I reboot and choose at the GRUB screen Ubuntu, the screen goes off(totally off), then on again and kinda blinking; I hear the welcome music of Ubuntu but I cannot see anything, except a very very thin line at the top of my screen where I can see the mouse.

It's weird, it did work on Live CD just fine, why is it crashing when It's installed? could be a graphics card problem? is there a way to fix such a thing?
P.S While the system is booting, I do not see the Ubuntu mark and the dots going to indicate it's loading, I have a blinking screen instead.

share|improve this question
2  
Most likely you have a UEFI machine (not BIOS) and a GUID partition table (GPT). If it's a small disk under 2TB then you can probably change the UEFI to legacy mode and use an MBR partition table. First though, you might be trying to use the 32 Ubuntu release. Download the 64 bit release and try that. –  fabricator4 Dec 1 '12 at 20:36
    
Well, I switched the UEFI to legacy and I am indeed using 64-bit release. Just thinking about something, can I juse gparted to erase the partition table? it seems I can but would that help? and what type of partitioning table should I use? –  xci13 Dec 1 '12 at 20:44
1  
If the drive is less than 2TB then you could just use the old DOS/MBR partition table. Yes Gparted will do it. It has no option for "delete" but use menu Device --> Create and it will write a new paritition table over the top of whatever is there. If you want select the advanced options to be sure it is writing a DOS (MBR) partition table but I believe that is the default. –  fabricator4 Dec 1 '12 at 21:02
1  
Oh, and support for 10.04 LTS runs out in April, so consider 12.04 LTS which will be supported for five years. –  fabricator4 Dec 1 '12 at 21:11
    
Please indicate your BootInfo URL. –  LovinBuntu Dec 1 '12 at 22:08
show 1 more comment

1 Answer

up vote 1 down vote accepted

okay so basically boot from the disk and open Gparted and create a comfortable partition for your ubuntu install (25GB IMO) start the installer it should detect windows and add it to its boot loader.

hope this helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.