Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded the "gspca" video for linux (v4l1) driver but when I tried to compile it, the terminal showed the following error:

$ cd gspcav1-20071224/
$ ~/gspcav1-20071224
$ ./gspca_build
bash: ./gspca_build: permission denied

I have no clue why I don't have permission in my own machine.

share|improve this question
    
you need to use the "sudo" command to do certain admin things. try that followed by your password –  Magpie Dec 5 '12 at 0:46
    
Can I ask why you needed to download the gspca driver? What webcam are you using and what version of Ubuntu are you trying? –  Luis Alvarado Dec 5 '12 at 1:16
    
The webcam is ID 0c45:602e Microdia VideoCAM Messenger and i can't make it work. I'm trying ubuntu 12.04 –  user112007 Dec 8 '12 at 17:21
    
I can use the webcam with Cheese but not with skype –  user112007 Dec 8 '12 at 18:00

2 Answers 2

up vote 1 down vote accepted

You need to grant execution permissions to the file. There are several ways to allow a file to be executed as a program :

  • Using Nautilus file manager, right click on your script file gspca_build and select Properties. Then go to the Permissions tab and check Allow executing file as program.

enter image description here

  • Using the command line, open a terminal and set gspca_build directory as your current directory. Then type the following command :

    sudo chmod +x gspca_build
    

You should now be able to execute your script.

share|improve this answer

Type

cd gspcav1-20071224/
~/gspcav1-20071224
$ sudo ./gspca_build
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.