Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sounds works for uid=1000, but not for the main user on the system, running with uid=1003. Upon boot, the Ubuntu chime clearly plays. When the user is logged in, sound test shows no input device.

I looked at several of the previous questions, added the user to audio, video, pulse, pulse-access --- but still no luck.

To recap: This worked perfectly in 11.04, 11.10, 12.04. It works for the default user uid=1000, it does not work for the actual user. The differing group memberships are mainly for adm, admin, sudo and the like.

Edit: Some exploring confirms that it is local to the user and machine; on a second box it works fine. So somewhere below ~/.gconf/ a toggle must have been flipped. And yes, reset alsamixer, reset mute button -- all to no avail.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

To debug or resolve this, please try the following steps:

  • remove all users (including user 1000) from the groups audio, pulse, pulse-access then reboot (no user needs to be in these groups for audio!).

  • Is pulseaudio running? Watch out for errors when running the following in a terminal:

    pulseaudio
    
  • log in to the Guest account. Does your guest user have sound?

  • From your affected user account issue the following command in a terminal:

    mv ~/.pulse/ ~/.pulse.bak/  ## removes erroneous user audio settings
    pulseaudio -k               ## restarts the sound server
    
  • Create a new test account to see if sound works there.

  • Do not run pulseaudio in system wide mode.

  • Is there an audio output sink at all? Read the output of the following command:

    pacmd list-sinks
    
  • Remove all attached external sound devices including speakers, reboot and then plug them back in.

  • Further reading: Ubuntu Wiki: Audio

share|improve this answer
    
Wonderfully precise answer, and spot on. I had suspected ~/.gconf/, and ~/.pulse it was. I now have a much happier 12-year being back to watch as watch YouTube as she wants. Thanks! –  Dirk Eddelbuettel Dec 2 '12 at 16:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.