Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got problem with updating. Sorry for polish language in log, but it is default language in my system. I'm using ubuntu 12.04 gnome remix.

Anybody know how to fix it?

Należy uruchomić "apt-get -f install", aby naprawić poniższe problemy: Następujące pakiety mają niespełnione zależności: libdrm-dev : Wymaga: > (= 2.4.40+git20121123.171666e4-0ubuntu0ricotz2~precise) ale >2.4.32-1ubuntu1 ma zostać zainstalowany libdrm-intel1 : Wymaga: libdrm2 (>= 2.4.38) ale 2.4.32-1ubuntu1 ma zostać zainstalowany libdrm-nouveau2 : Wymaga: libdrm2 (>= 2.4.38) ale 2.4.32-1ubuntu1 ma zostać zainstalowany libdrm-radeon1 : Wymaga: libdrm2 (>= 2.4.38) ale 2.4.32-1ubuntu1 ma zostać zainstalowany libdrm2 : Narusza zależności: libdrm2:i386 (!= 2.4.32-1ubuntu1) ale >2.4.40+git20121123.171666e4-0ubuntu0ricotz2~precise ma zostać zainstalowany libdrm2:i386 : Narusza zależności: libdrm2 (!= 2.4.40+git20121123.171666e4->0ubuntu0ricotz2~precise) ale 2.4.32-1ubuntu1 ma zostać zainstalowany

You should run "apt-get-f install" to fix the following problems: The following packages have unmet dependencies: libdrm-dev: Depends:> (= 4.2.40 + git20121123.171666e4-0ubuntu0ricotz2 ~ precise) but> 2.4.32-1ubuntu1 is to be installed libdrm-intel1: Requires: libdrm2 (> = 2.4.38) but 2.4.32-1ubuntu1 is to be installed libdrm-nouveau2: Requires: libdrm2 (> = 2.4.38) but 2.4.32-1ubuntu1 is to be installed libdrm -radeon1: Requires: libdrm2 (> = 2.4.38) but 2.4.32-1ubuntu1 is to be installed libdrm2: depending violates: libdrm2: i386 (! = 2.4.32-1ubuntu1) but> 4.2.40 + git20121123.171666e4-0ubuntu0ricotz2 ~ precise to be installed libdrm2: i386: depending violates: libdrm2 (! = 2.4.40 + git20121123.171666e4-> 0ubuntu0ricotz2 ~ precise) but 2.4.32-1ubuntu1 is to be installed

share|improve this question
    
checked it before posting. Don't work. –  Grzesiek Szczurek Dec 2 '12 at 15:00
1  
you can try also sudo apt-get -r install libdrm-dev ... OR restart to Recovery kernel and run 'dpkg' ... –  swift Dec 2 '12 at 16:23
    
you mean sudo apt-get -f install libdrm-dev ?? Not -r? Checked too. I checked other kernel too but it still don't work –  Grzesiek Szczurek Dec 2 '12 at 18:10
    
no, not --fix but --reinstall option –  swift Dec 3 '12 at 0:14
    
sudo apt-get -f install - to common system fix, sudo apt-get -r install libdrm-dev - to reinstall package, but most credible is it also reinstall signed packages from ricotz ppa –  swift Dec 3 '12 at 0:40
show 1 more comment

1 Answer 1

Figured it out.

Image by WebUpd8 Image by Alin Andrey, WebUpd8

It is problem with your xorg-edgers packages ...

xorg-edgers precise ppa

Thus. I have not idea why your packages was downgraded, or some package that tried to be updated have dependencies to updated package. Possible way it is:

Check your Software Sources.

If it needed install ppa-purge:
sudo apt-get install ppa-purge

Refer to this link for how-to-use ppa-purge:
Install PPA-Purge With Multi-Arch Support In Ubuntu

Thus, first need to fix your Software Sources that to provide automatic updates.

share|improve this answer
    
But I can not install anything ;/ –  Grzesiek Szczurek Dec 5 '12 at 19:03
    
then refer this: Package Manager Troubleshooting Procedure ... and please post your output. –  swift Dec 6 '12 at 3:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.