Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had the ubuntu 12.10 up and running. But somehow I managed to mess it all up. Now, I do not get the login screen. It keeps on getting a black screen and cursor blink at something " Jupiter healthcheck ".

Pressing random keys, I could get to the terminal.

I tried this:

 sudo apt-get install ubuntu-desktop

Output was :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntu-desktop : Depends: nautilus but it is not going to be installed
                  Depends: nautilus-sendto but it is not going to be installed
                  Recommends: brasero but it is not going to be installed
                  Recommends: nautilus-share but it is not going to be installed
                  Recommends: transmission-gtk but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How do I get go ahead ?

share|improve this question
    
try sudo apt-get install -f & sudo apt-get upgrade. then use sudo apt-get install --reinstall ubuntu-desktop and sudo apt-get install unity –  Web-E Dec 1 '12 at 13:35
    
Did everything you said. But no success. Unity is installed already. And the reinstall command gives the same output as above. –  Tatsat Dec 1 '12 at 13:58
    
Please post the output of dpkg --get-selection | grep hold. Also, please try to install one of the packages that is complaining, like nautilus. You should get more informative error messages. If you get the same thing again, keep trying on the new package until you get something with more detail. –  dpb Dec 1 '12 at 15:59

1 Answer 1

It seems that you have some repos disabled. First of all, let's reenable them with this command:

 sudo software-properties-gtk -e universe multiverse restricted

After that, install the ubuntu-desktop:

 sudo apt-get update && sudo apt-get install ubuntu-desktop

NOTE

If you don't have software-properties-gtk installed, then install it with:
sudo apt-get install software-properties-gtk
command.

share|improve this answer
    
I followed everything you said. But the response to installing ubuntu-desktop is the same as above. –  Tatsat Dec 1 '12 at 14:12
    
Ok, how about sudo apt-get install unity? –  Frantique Dec 1 '12 at 15:08
    
Already did that. It was installed alright. –  Tatsat Dec 1 '12 at 17:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.