Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 12.10 64 bit on a Dell E5410 Latitude. Everything was working nicely until I tried to install Avast antivirus program. This froze my system and I proceeded to remove --purge the program.

Now I'm in the situation that at the login screen I can no longer use my standard (admin) user accounts through the graphical interface. When I enter my password the screen goes black flashes code for a milisecond and then returns to the unity login screen. using an alternative terminal (i.e. ALT+F3) I can login normally. using my guest account I can also login to graphics mode without an issue.

I've tried unity --reset, the out put is shown as "The reset option is now deprecated" I'm hesitant to start messing with ccsm for the moment as it sounds like I could potentially do more harm then good.

the '.xsession-errors' (which I can only access from the guest account) does not make me any wiser. Neither does the '/var/log/Xorg.0.log' provide any obvious clue.

I have no idea if I'm even on the right track and feel that my google and forum searches are no longer giving me more clarity. hoping some one can help with this.

All the best from Malawi, Daniel

share|improve this question

closed as too localized by Jorge Castro, Ringtail, fossfreedom Dec 11 '12 at 10:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I've been doing some more exploring and have been able to read the error text on which the graphics logon hangs. It states something about mountall failed and plymouth not working (sorry can't seem to reproduce the exact text) I've looked at my swap and other drives and see that some of them do not have a valid partion table but then again these are all of format dev/mapper/.... so not sure if this is an error or as it should be. as you might have noticed I'm pretty new at all of this so any help would be greatly appreciated. Cheers, Dan –  Dohyedan Dec 1 '12 at 14:08
    
Still working on this... I think I've now figured out what is causing the problem. by going through the syslog file I found: Error attempting to parse .ecryptfsrc file; RC = [-13] pam_ecryptfs: Passphrase file wrapped Error attempting to open [/home/me/ecryptfs/wrapped-passphrase] for reading Error attempting to unwrap passphrase from file [/home/me/ecryptfs/wrapped-passphrase] for reading; RC = [-5] `pam_ecryptfs: Error adding passphrase key token to user session keyring; RC [-5] still no idea how to solve this... help greatly appreciated :-D –  Dohyedan Dec 2 '12 at 17:17
    
Okay I ran ecryptfs-recover-private according to [link] (blog.dustinkirkland.com/2011/04/…) with success. at least it says it has recovered my private data read only in temp directory. Following the guide however I can't start up nautilus (sudo nautilus): no protocol specified **(nautilus 14531) WARNING: **: could not open X display could not parse arguments: Cannot open display: Also tried ecryptfs-mount-private: ERROR: Encrypted private directory is not setup properly. Any ideas?....... –  Dohyedan Dec 3 '12 at 7:37

1 Answer 1

After more research which led to no obvious solution and the lack of response on this forum I fixed the problem through a fresh Ubuntu install and restoring my /home/ from a month old backup. not the brightest day in my budding Ubuntu problem solving career I guess but hey such is life.

PS. If you reading this because you are experiencing the same problem, all I can say is that I really hope someone comes to your help.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.