Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I wonder whether there's a way to make urxvt render xft fonts:

URxvt.font: xft:Droid Sans Mono Slashed:pixelsize=9:Regular
URxvt.boldFont: xft:Droid Sans Mono Slashed:pixelsize=9:Bold
URxvt.talicFont: xft:Droid Sans Mono Slashed:pixelsize=9:Italic
URxvt.bolditalicFont: xft:Droid Sans Mono Slashed:pixelsize=9:Bold:Italic

If I try this, I get something like: alt text

So it scales pretty bad:

 ! Fonts
 Xft.dpi:        132
 Xft.antialias:  true
 Xft.rgba:       rgb
 Xft.hinting:    true
 Xft.autohint:  true
 Xft.hintstyle:  hintfull   

I'm not sure whether this is one of the reaons. However I want antialias and that Droid. Is there any trick here?

share|improve this question

5 Answers 5

urxvt will use a default font if it cannot find the xft font name you specify. For example, the following will look like your screenshot:

urxvt -fn 'xft:foo'

To find out which xft fonts you have available, run:


Here is how I run urxvt with the beautiful Ubuntu Monospace font:

urxvt -fn "xft:Ubuntu Mono:pixelsize=14,style=regular"
share|improve this answer

I got it just working with command line option "-letsp -1", see also

share|improve this answer

I have this in my .Xdefaults and Droid Sans Mono looks great:

!-- Xft settings -- !
Xft.dpi:        96
Xft.antialias:  true
Xft.rgba:       rgb
Xft.hinting:    true
Xft.hintstyle:  hintslight

! -- Fonts -- !
URxvt.font:xft:droid sans mono slashed:medium:pixelsize=11
URxvt.boldFont:xft:droid sans mono slashed:medium:pixelsize=11
share|improve this answer
That's funny because both Xft.rgba: rgb (instead of none) and Xft.hintstyle: hintslight (and hintfull) trigger the described behavior for me. See –  balu Mar 13 at 2:56

Please note that there's a bug report regarding letter spacing. There's a work-around, though, which was proposed in the bug discussion and which I repeated over at (in case you can't find it).

share|improve this answer

If I remember, the spacing was fixed by

URxvt*letterSpace: -2

This is my .Xresources:

Xft.dpi:                    96
Xft.antialias:              true
Xft.rgba:                   rgb
Xft.hinting:                true
Xft.hintstyle:              hintslight

URxvt.depth: 0

URxvt.intensityStyles:  false                                       
! Turn it on here... (then boldFont)
URxvt.allow_bold:       false                                        
URxvt.font:             xft:Ubuntu Mono:style=Regular:pixelsize=17
! ... but put this on Regular, else the ls output is overly fat
URxvt.boldFont:         xft:Ubuntu Mono:style=Bold:pixelsize=17  
URxvt.saveLines:        8192

! Fix font space
! any larger than -1 I dont like
URxvt*letterSpace: -2                                               
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.