Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.10 on my new machine, and I'm trying to install Ushare from the source from the website. I would just install it through the terminal using 'sudo apt-get install ushare' but I am tweaking the mime.c file so that it'll stream mp4 files as video. Now, I had written a neat little script that did it all nice and neat for me on my Ubuntu 12.04 machine, but now when I run the 'make' command, it is giving me the message:

"error: ‘struct sockaddr_storage’ has no member named ‘s_addr’"

I appreciate any help!

share|improve this question

closed as off-topic by Braiam, Seth, Lucio, Amith KK, Olli Feb 16 at 11:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Seth, Lucio, Amith KK
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Got the same error with the sources of ushare-1.1a, anyone ever solved this? –  Ian Mar 30 '13 at 9:29

1 Answer 1

The problem is the version of libupnp. Make by libupnp-1.4.2.

share|improve this answer
    
Could you provide more specific instructions, please? I have an older version of this app running on a box and this might be helpful to me as well. Thanks. –  Kevin Bowen Jun 2 '13 at 10:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.