Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 10.10 netbook edition. I have some data on a thumb drive that I want to put on my computer but when I plug in the thumb drive, nothing happens. I search for the file and it's not there. /media is empty. How do I mount this thumbrive and make it mount automatically?

output of dmesg. The Total output was too large, so I put in what I thought would be relevant:

[ 2043.086937] wlan0: associated
[ 2523.345076] usb 1-3: new high speed USB device using ehci_hcd and address 3
[ 2523.647942] Initializing USB Mass Storage driver...
[ 2523.648585] scsi4 : usb-storage 1-3:1.0
[ 2523.649787] usbcore: registered new interface driver usb-storage
[ 2523.649796] USB Mass Storage support registered.
[ 2524.660116] scsi 4:0:0:0: Direct-Access     TOSHIBA  TransMemory      5.00 PQ: 0 ANSI: 0 CCS
[ 2524.665393] sd 4:0:0:0: Attached scsi generic sg1 type 0
[ 2525.902179] sd 4:0:0:0: [sdb] 4028416 512-byte logical blocks: (2.06 GB/1.92 GiB)
[ 2525.902776] sd 4:0:0:0: [sdb] Write Protect is off
[ 2525.902787] sd 4:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 2525.902795] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 2525.906549] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 2525.906570]  sdb: sdb1
[ 2525.910640] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 2525.910656] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[ 2638.233056] usb 1-3: USB disconnect, address 3
[ 2643.460114] usb 1-3: new high speed USB device using ehci_hcd and address 4
[ 2643.598968] scsi5 : usb-storage 1-3:1.0
[ 2644.596900] scsi 5:0:0:0: Direct-Access     TOSHIBA  TransMemory      5.00 PQ: 0 ANSI: 0 CCS
[ 2644.599789] sd 5:0:0:0: Attached scsi generic sg1 type 0
[ 2644.819235] sd 5:0:0:0: [sdb] 4028416 512-byte logical blocks: (2.06 GB/1.92 GiB)
[ 2644.819872] sd 5:0:0:0: [sdb] Write Protect is off
[ 2644.819884] sd 5:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 2644.819892] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[ 2644.825499] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[ 2644.825533]  sdb: sdb1
[ 2644.834616] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[ 2644.834632] sd 5:0:0:0: [sdb] Attached SCSI removable disk
[ 2925.444581] usb 1-3: USB disconnect, address 4
[ 3090.808101] usb 1-3: new high speed USB device using ehci_hcd and address 5
[ 3090.945921] scsi6 : usb-storage 1-3:1.0
[ 3091.944884] scsi 6:0:0:0: Direct-Access     TOSHIBA  TransMemory      5.00 PQ: 0 ANSI: 0 CCS
[ 3091.946451] sd 6:0:0:0: Attached scsi generic sg1 type 0
[ 3093.224574] sd 6:0:0:0: [sdb] 4028416 512-byte logical blocks: (2.06 GB/1.92 GiB)
[ 3093.225499] sd 6:0:0:0: [sdb] Write Protect is off
[ 3093.225517] sd 6:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 3093.225527] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 3093.229707] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 3093.229762]  sdb: sdb1
[ 3093.232970] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 3093.232993] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[ 3134.507536] usb 1-3: USB disconnect, address 5
[ 3139.169115] usb 1-1: new high speed USB device using ehci_hcd and address 6
[ 3139.308938] scsi7 : usb-storage 1-1:1.0
[ 3140.308945] scsi 7:0:0:0: Direct-Access     TOSHIBA  TransMemory      5.00 PQ: 0 ANSI: 0 CCS
[ 3140.310423] sd 7:0:0:0: Attached scsi generic sg1 type 0
[ 3140.550352] sd 7:0:0:0: [sdb] 4028416 512-byte logical blocks: (2.06 GB/1.92 GiB)
[ 3140.551040] sd 7:0:0:0: [sdb] Write Protect is off
[ 3140.551059] sd 7:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 3140.551072] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[ 3140.557789] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[ 3140.557821]  sdb: sdb1
[ 3140.564267] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[ 3140.564279] sd 7:0:0:0: [sdb] Attached SCSI removable disk
[ 4639.380928] usb 1-1: USB disconnect, address 6
[ 4749.180094] usb 1-3: new high speed USB device using ehci_hcd and address 7
[ 4749.319077] scsi8 : usb-storage 1-3:1.0
[ 4750.316850] scsi 8:0:0:0: Direct-Access     TOSHIBA  TransMemory      5.00 PQ: 0 ANSI: 0 CCS
[ 4750.319861] sd 8:0:0:0: Attached scsi generic sg1 type 0
[ 4752.278001] sd 8:0:0:0: [sdb] 4028416 512-byte logical blocks: (2.06 GB/1.92 GiB)
[ 4752.278603] sd 8:0:0:0: [sdb] Write Protect is off
[ 4752.278616] sd 8:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 4752.278626] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 4752.283289] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 4752.283320]  sdb: sdb1
[ 4752.289263] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 4752.289286] sd 8:0:0:0: [sdb] Attached SCSI removable disk
share|improve this question
    
See the output of dmesg after inserting the drive. –  enzotib Jan 20 '11 at 13:38

2 Answers 2

The thumbdrive should mount automatically. If not, it is quite possible the filesystem is corrupted. Indeed, see the output of dmesg (find the Log File Viewer in System»Administration) and observe any messages that appear as soon as you plug in the thumbdrive.

If the thumbdrive's filesystem is indeed corrupted, there is a process to extract your files, at least some of them.

Update: Try to mount the USB stick manually.

  1. Open a terminal window
  2. Run mkdir /tmp/mountpoint
  3. Run mount /dev/sdb1 /tmp/mountpont

Observe any errors.

If there is no error from the last command, then look into /tmp/mountpoint/ your files should be in there. At this point we can try to figure out why automount does not work.

share|improve this answer
    
thumbdrive's filesystem isn't corrupted. (I've reformatted the thumbdrive a couple times trying to get this to work using FAT and ext4). I can't find system>>administration because this is the netbook edition. –  oadams Jan 20 '11 at 13:53
    
Great, thanks. I tried that, and got my files off the usb drive. Any ideas about how to find out what's going on with automount? –  oadams Jan 20 '11 at 14:19
    
Please check next answer and tell us if it's fixed. –  luri Jan 20 '11 at 14:59

Some options to check (I'd start on points 3 and 5):

  1. Check this question, too: USB Storage Device Automount, and try the solutions proposed there.
  2. Also, you can try palimpsest to mount it (update: you already mounted it, so no need to do this)
  3. In 10.04 (some people reported it with 10.10, too) there seemed to be a bug that prevented usb automounting. Don't know if that's fixed, but you can try the solution for that case (note that it disables floppy support): sudo modprobe -r floppy (source)
  4. Yet another possibility (quoting this):

    I eventually solved this problem by uninstalling pmount, then re-installing together with libpmount0.0

    Now drives are detected, automount and can be safely removed. No idea what caused the problem on the upgrade, but hope that this helps other people with the same problem.

  5. Here you can find another workaround:

    sudo gedit /etc/modules

    Add two lines (at the end of file):

    usb_storage

    usbhid

(Actually you can check with modprobe -l |grep usbhid and modprobe -l |grep usb_storageif those moduled are already loaded or not before doing the edit)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.