Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was running ubuntu 11.10 without major flaws and somewhat adapted to my taste and decided to give upgrading another shot. Somehow I do so every couple of years and every time I face reinstall. This time, I'm not giving up just yet. I got to 12.04 after just half a day of fiddling with it, everything worked except wifi and the css being messed up but I wanted to go on to 12.10. I managed to start the upgrade with little frustration and as it was about 10% through the install step, I accidentally pressed the up key on one of my terminal sessions and boom apt-get clean. During upgrade. Of course it died, threw error after error, would not let me cancel would not finish configuring at least what had been installed already. So I killed it. I was able to reboot and uninstall reinstall configure some things but after a reboot I couldn't even get into recovery mode. So I'm in live mode using chroot and these are my outputs. I don't seem to have the internet connection available through chroot but from the output you can see that there's nothing in the sources.

clean, autoclean, autoremove

root@ubuntu:/# apt-get clean
root@ubuntu:/# apt-get autoclean
Reading package lists... Done
Building dependency tree      
Reading state information... Done
root@ubuntu:/# apt-get autoremove
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 apturl-common : Depends: python3-update-manager but it is not installed
 ca-certificates-java : Depends: ca-certificates (>= 20121114) but 20111211 is     installed
 chromium-browser-l10n : Depends: chromium-browser (= 22.0.1229.94~r161065-0ubuntu1)     but 20.0.1132.47~r144678-0ubuntu0.12.04.1 is installed
 e2fsprogs : PreDepends: e2fslibs (= 1.42-1ubuntu2) but 1.42.5-1ubuntu3 is installed
 gir1.2-mutter-3.0 : Depends: libmutter0a but it is not installable
 gnome-orca : Depends: python3-speechd (>= 0.6.2) but it is not installed
 gnome-shell : Depends: libmutter0a but it is not installable
               Recommends: gnome-user-guide but it is not installed
 libexttextcat0 : Depends: libexttextcat-data (= 3.2.0-1ubuntu1) but 3.4.0-1 is     installed
 libmutter0 : Depends: mutter-common (= 3.6.1-0ubuntu1) but 3.6.2-0ubuntu1 is installed
 libreoffice-base-core : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but     1:3.5.4-0ubuntu1.1 is installed
 libreoffice-calc : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
 libreoffice-common : Breaks: libreoffice-style-tango (>= 1:3.6~) but 1:3.6.2~rc2-0ubuntu6 is installed
 libreoffice-draw : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
                Recommends: libreoffice-pdfimport but it is not installed
 libreoffice-gnome : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
 libreoffice-gtk : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
 libreoffice-impress : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
 libreoffice-math : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
 libreoffice-writer : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
 mahjongg : Depends: gnome-mahjongg but it is not installed
 module-init-tools : Depends: kmod but it is not installable
 python-uno : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but     1:3.5.4-0ubuntu1.1 is installed
 python3-distupgrade : Depends: python3-update-manager but it is not installed
 rpm : Depends: rpm-common (= 4.10.1-2) but 4.9.1.1-1build1 is installed
 rpm2cpio : Depends: rpm-common (= 4.10.1-2) but 4.9.1.1-1build1 is installed
 ubuntuone-control-panel-qt : Depends: python-ubuntuone-control-panel (= 3.0.1-0ubuntu1) but 4.0.0-0ubuntu1 is installed
                          Depends: ubuntuone-control-panel (= 3.0.1-0ubuntu1) but     4.0.0-0ubuntu1 is installed
 update-manager-core : Depends: python3-update-manager (= 1:0.174.3) but it is not installed
 vlc-nox : Depends: libupnp6 (>= 1.4.3) but it is not installed
E: Unmet dependencies. Try using -f.
root@ubuntu:/# 

update upgrade dist-upgrade

    root@ubuntu:/# apt-get update
    Err http://archive.ubuntu.com quantal InRelease
    Err http://archive.ubuntu.com quantal-updates InRelease
    Err http://archive.ubuntu.com quantal-security InRelease
    Err http://archive.ubuntu.com quantal Release.gpg
    Could not resolve 'archive.ubuntu.com'
    Err http://archive.ubuntu.com quantal-updates Release.gpg
    Could not resolve 'archive.ubuntu.com'
    Err http://archive.ubuntu.com quantal-security Release.gpg
    Could not resolve 'archive.ubuntu.com'
    Reading package lists... Done
    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal/InRelease
    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal-updates/InRelease
    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal-security/InRelease
    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal/Release.gpg Could not resolve 'archive.ubuntu.com'
    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal-updates/Release.gpg Could not resolve 'archive.ubuntu.com'
    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal-security/Release.gpg Could not resolve 'archive.ubuntu.com'
    W: Some index files failed to download. They have been ignored, or old ones used instead.
    root@ubuntu:/# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    apturl-common : Depends: python3-update-manager but it is not installed
    ca-certificates-java : Depends: ca-certificates (>= 20121114) but 20111211 is installed
    chromium-browser-l10n : Depends: chromium-browser (= 22.0.1229.94~r161065-0ubuntu1) but 20.0.1132.47~r144678-0ubuntu0.12.04.1 is installed
    e2fsprogs : PreDepends: e2fslibs (= 1.42-1ubuntu2) but 1.42.5-1ubuntu3 is installed
    gir1.2-mutter-3.0 : Depends: libmutter0a but it is not installable
    gnome-orca : Depends: python3-speechd (>= 0.6.2) but it is not installed
    gnome-shell : Depends: libmutter0a but it is not installable
    Recommends: gnome-user-guide but it is not installed
    libexttextcat0 : Depends: libexttextcat-data (= 3.2.0-1ubuntu1) but 3.4.0-1 is installed
    libmutter0 : Depends: mutter-common (= 3.6.1-0ubuntu1) but 3.6.2-0ubuntu1 is installed
    libreoffice-base-core : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-calc : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-common : Breaks: libreoffice-style-tango (>= 1:3.6~) but 1:3.6.2~rc2-0ubuntu6 is installed
    libreoffice-draw : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    Recommends: libreoffice-pdfimport but it is not installed
    libreoffice-gnome : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-gtk : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-impress : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-math : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-writer : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    mahjongg : Depends: gnome-mahjongg but it is not installed
    module-init-tools : Depends: kmod but it is not installable
    python-uno : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    python3-distupgrade : Depends: python3-update-manager but it is not installed
    rpm : Depends: rpm-common (= 4.10.1-2) but 4.9.1.1-1build1 is installed
    rpm2cpio : Depends: rpm-common (= 4.10.1-2) but 4.9.1.1-1build1 is installed
    ubuntuone-control-panel-qt : Depends: python-ubuntuone-control-panel (= 3.0.1-0ubuntu1) but 4.0.0-0ubuntu1 is installed
    Depends: ubuntuone-control-panel (= 3.0.1-0ubuntu1) but 4.0.0-0ubuntu1 is installed
    update-manager-core : Depends: python3-update-manager (= 1:0.174.3) but it is not installed
    vlc-nox : Depends: libupnp6 (>= 1.4.3) but it is not installed
    E: Unmet dependencies. Try using -f.
    root@ubuntu:/# apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    apturl-common : Depends: python3-update-manager but it is not installed
    ca-certificates-java : Depends: ca-certificates (>= 20121114) but 20111211 is installed
    chromium-browser-l10n : Depends: chromium-browser (= 22.0.1229.94~r161065-0ubuntu1) but 20.0.1132.47~r144678-0ubuntu0.12.04.1 is installed
    e2fsprogs : PreDepends: e2fslibs (= 1.42-1ubuntu2) but 1.42.5-1ubuntu3 is installed
    gir1.2-mutter-3.0 : Depends: libmutter0a but it is not installable
    gnome-orca : Depends: python3-speechd (>= 0.6.2) but it is not installed
    gnome-shell : Depends: libmutter0a but it is not installable
    Recommends: gnome-user-guide but it is not installed
    libexttextcat0 : Depends: libexttextcat-data (= 3.2.0-1ubuntu1) but 3.4.0-1 is installed
    libmutter0 : Depends: mutter-common (= 3.6.1-0ubuntu1) but 3.6.2-0ubuntu1 is installed
    libreoffice-base-core : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-calc : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-common : Breaks: libreoffice-style-tango (>= 1:3.6~) but 1:3.6.2~rc2-0ubuntu6 is installed
    libreoffice-draw : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    Recommends: libreoffice-pdfimport but it is not installed
    libreoffice-gnome : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-gtk : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-impress : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-math : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    libreoffice-writer : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    mahjongg : Depends: gnome-mahjongg but it is not installed
    module-init-tools : Depends: kmod but it is not installable
    python-uno : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
    python3-distupgrade : Depends: python3-update-manager but it is not installed
    rpm : Depends: rpm-common (= 4.10.1-2) but 4.9.1.1-1build1 is installed
    rpm2cpio : Depends: rpm-common (= 4.10.1-2) but 4.9.1.1-1build1 is installed
    ubuntuone-control-panel-qt : Depends: python-ubuntuone-control-panel (= 3.0.1-0ubuntu1) but 4.0.0-0ubuntu1 is installed
    Depends: ubuntuone-control-panel (= 3.0.1-0ubuntu1) but 4.0.0-0ubuntu1 is installed
    update-manager-core : Depends: python3-update-manager (= 1:0.174.3) but it is not installed
    vlc-nox : Depends: libupnp6 (>= 1.4.3) but it is not installed
    E: Unmet dependencies. Try using -f.
    root@ubuntu:/#

-f install

        root@ubuntu:/# apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
     apturl-common : Depends: python3-update-manager but it is not installed
     ca-certificates-java : Depends: ca-certificates (>= 20121114) but 20111211 is installed
     chromium-browser-l10n : Depends: chromium-browser (= 22.0.1229.94~r161065-0ubuntu1) but 20.0.1132.47~r144678-0ubuntu0.12.04.1 is installed
     e2fsprogs : PreDepends: e2fslibs (= 1.42-1ubuntu2) but 1.42.5-1ubuntu3 is installed
     gir1.2-mutter-3.0 : Depends: libmutter0a but it is not installable
     gnome-orca : Depends: python3-speechd (>= 0.6.2) but it is not installed
     gnome-shell : Depends: libmutter0a but it is not installable
                   Recommends: gnome-user-guide but it is not installed
     libexttextcat0 : Depends: libexttextcat-data (= 3.2.0-1ubuntu1) but 3.4.0-1 is installed
     libmutter0 : Depends: mutter-common (= 3.6.1-0ubuntu1) but 3.6.2-0ubuntu1 is installed
     libreoffice-base-core : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
     libreoffice-calc : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
     libreoffice-common : Breaks: libreoffice-style-tango (>= 1:3.6~) but 1:3.6.2~rc2-0ubuntu6 is installed
     libreoffice-draw : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
                        Recommends: libreoffice-pdfimport but it is not installed
     libreoffice-gnome : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
     libreoffice-gtk : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
     libreoffice-impress : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
     libreoffice-math : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
     libreoffice-writer : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
     mahjongg : Depends: gnome-mahjongg but it is not installed
     module-init-tools : Depends: kmod but it is not installable
     python-uno : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu6) but 1:3.5.4-0ubuntu1.1 is installed
     python3-distupgrade : Depends: python3-update-manager but it is not installed
     rpm : Depends: rpm-common (= 4.10.1-2) but 4.9.1.1-1build1 is installed
     rpm2cpio : Depends: rpm-common (= 4.10.1-2) but 4.9.1.1-1build1 is installed
     ubuntuone-control-panel-qt : Depends: python-ubuntuone-control-panel (= 3.0.1-0ubuntu1) but 4.0.0-0ubuntu1 is installed
      Depends: ubuntuone-control-panel (= 3.0.1-0ubuntu1) but 4.0.0-0ubuntu1 is installed
     update-manager-core : Depends: python3-update-manager (= 1:0.174.3) but it is not installed
     vlc-nox : Depends: libupnp6 (>= 1.4.3) but it is not installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies

dpkg.log blablabla 2012-12-01 01:11:49 status half-configured python3.3:amd64 3.3.0-4 2012-12-01 01:11:49 configure unattended-upgrades:all 0.79.3ubuntu6 2012-12-01 01:11:49 status half-configured unattended-upgrades:all 0.79.3ubuntu6 2012-12-01 01:11:49 configure dmsetup:amd64 2:1.02.74-5ubuntu1 2012-12-01 01:11:49 status half-configured dmsetup:amd64 2:1.02.74-5ubuntu1 2012-12-01 01:11:51 configure python3:amd64 3.3.0-0ubuntu3 2012-12-01 01:11:51 status half-configured python3:amd64 3.3.0-0ubuntu3 2012-12-01 01:11:51 configure apparmor:amd64 2.8.0-0ubuntu7 2012-12-01 01:11:51 status half-configured apparmor:amd64 2.8.0-0ubuntu7 2012-12-01 01:11:52 configure initramfs-tools:all 0.103ubuntu0.3 2012-12-01 01:11:52 status half-configured initramfs-tools:all 0.103ubuntu0.3

dpkg --configure -a --force-all (does a whole lot of nothing and ends with this:)

    /usr/sbin/mkinitramfs: 54: /usr/sbin/mkinitramfs: modprobe: not found
    /usr/sbin/mkinitramfs: 136: /usr/sbin/mkinitramfs: cannot create /dev/null: Permission denied
    /usr/sbin/mkinitramfs: 136: /usr/sbin/mkinitramfs: cannot create /dev/null: Permission denied
    /usr/sbin/mkinitramfs: 278: /usr/sbin/mkinitramfs: cannot create /dev/null: Permission denied
    WARNING: no ldd around - install libc-bin
    update-initramfs: failed for /boot/initrd.img-3.2.0-34-generic with 1.
    dpkg: error processing initramfs-tools (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     sudo
     openjdk-7-jre-headless:amd64
     login
     python-minimal
     ntfs-3g
     dbus
     aspell-en
     resolvconf
     python3.3-minimal
     samba-common
     x11-common
     bash-completion
     gconf2
     cron
     util-linux
     pulseaudio
     winbind
     python3.3
     unattended-upgrades
     dmsetup
     python3
     apparmor
     initramfs-tools

does anybody know any way of removing those unmet dependencies, reinstalling them, configuring them, upgrading my os so that I can use it again? Thanks!


I got a step further! just now had dpkg install many packages over. After this, the configure which failed but after that -f install which magically even tried to remove and reinstall some things! This is an epic success, I'll try to download what's needed in my live system and feed it to it through dpkg

I'll keep you posted.

share|improve this question

2 Answers 2

Basically it looks like your trying to go too far.

Try updating in smaller increments. According to your sources you going from 11.10 to 12.10. Instead try upgrading to 12.04

Also you have some

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal/InRelease
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal-updates/InRelease
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal-security/InRelease
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal/Release.gpg Could not resolve 'archive.ubuntu.com'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal-updates/Release.gpg Could not resolve 'archive.ubuntu.com'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal-security/Release.gpg Could not resolve 'archive.ubuntu.com'

This means your missing quite a few of the CORE packages you need.

Start by resolving the error reaching your repositories then try the update again.

If you can't reach archive.ubuntu.com try one of the mirrors here.

Once you are able to actually fetch the package list things should resolve themselves.

Try this answer for help resolving the repo.

share|improve this answer
    
Hi there, thanks for the lightning quick reply! I did go to 12.04 which went well and from there to 12.10 which didn't. the errors occur because gnome-shell is half installed and hence the system hardly boots into a terminal window let alone uses my wifi connection. Which is why I'm in a live system using chroot. Apparently, the chrooted root does not see my internet connection. If you know a fix, do let me know. –  Philipp Dec 1 '12 at 9:28
    
Until you can fix those fetch errors it's not really safe to do anything (with apt). You can try cnetworkmanager if you can manage to get it installed. When you chroot, current config files take over. So /etc/resolv.conf (inside chroot) will need to be updated. –  coteyr Dec 1 '12 at 18:22

solved it in the end by dumping the packages manually that would allow me to boot into it again, did that, installed, configured, updated, upgraded, dist-upgraded, reconfigured etc until it worked. Also got new shell etc all nice and smooth. Thanks though!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.