Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to start Ubuntu from my USB key in UEFI mode (it works in Legacy mode, but I have to keep Windows) on a Dell Inspiron 15z , Grub starts, but when I choose any option, I get a black screen and my USB key stop teling me it is being read.

EDIT: when using the legacy mode and trying to install Ubuntu, I get a blank partition table with Ubiquity…

Ubiquity doesn't see any partitions

… and a very strange partition table from GParted (I have a hybrid 32Go SSD + 500Go HDD disk) :

An error about the GPT table not at the end…

… and again…

… and again…

This is my 500Go hard drive.

And this is my 32Go SSD.

share|improve this question
add comment

3 Answers

Those partitioning errors suggest that you've either got a damaged partition table or you've got a system that's confused about RAID options. The latter seems more likely. Either the disk was partitioned with RAID features active but you're reading it in Linux with RAID inactive or vice-versa. Either way, you should work to get the RAID situation sorted out. Check the options in the firmware and in Windows related to RAID. If it's active, you probably need to ensure that the dmraid package is up and running in the Ubuntu installer; if not, you need to uninstall it, and you may need to remove stray RAID data. I'm afraid I don't have more detailed references handy, but some Web searches should turn up more information.

Concerning your inability to boot in EFI mode, I'm not entirely sure what's going wrong, although it could be related to Secure Boot. You could try disabling this feature in your firmware. (Ubuntu 12.10 supposedly includes Secure Boot support, but this feature is brand-new and may yet be buggy on some systems.) It's also possible you're running into a GRUB bug. Note that it is possible to install Ubuntu in BIOS/legacy mode and then switch the boot mode. For greatest flexibility, I recommend you create a separate FAT, ext2fs, ext3fs, or ReiserFS /boot partition when you install. This will make it relatively easy to experiment with certain boot loaders and boot managers, such as rEFInd, gummiboot, and ELILO. All of these boot programs require that the kernel be readable by the EFI, which can be arranged if the kernel is on a FAT, ext2fs, ext3fs, or ReiserFS partition. (For anything but FAT, you'll need filesystem drivers that ship with rEFInd.) You can install one of these programs from Windows and configure it to boot your Linux kernel in EFI mode, which can simplify the process of converting from a BIOS/legacy-mode boot to an EFI-mode boot.

share|improve this answer
    
I disabled Secure Boot, and I have the same problems. –  NicoGuich Dec 1 '12 at 11:55
add comment
up vote 1 down vote accepted

Thanks everyone, I have found the solution, I had two problems:

  • Ubuntu didn't want to boot in EFI mode, except when the firmware was set to Legacy (and let me boot using EFI ¿).
  • I just clicked "Fix" in all the question screen-shots and then, GPARTED let me change everything I wanted and Ubiquity let me install Ubuntu !

The installation has just finish and I'm going to reboot now.

share|improve this answer
add comment

I'm running this laptop with Ubuntu GNOME 13.04.

The first step is to disable SSD as a cache from Windows, using Intel Matrix Storage software. Yes, it can't be done through the firmware. Without that, you won't be able to use more than 8GB on the SSD.

If you want to boot automatically in UEFI, you need to disable Legacy. Currently, Linux is hitting bug with the NIC card in full UEFI mode, so you have to disable it. Once you booted Ubuntu in UEFI mode, you'll notice you wont have sound either.

That's a trade off. I suggest you to keep using legacy mode until full support is here.

Regards,

share|improve this answer
    
Now, it's good… No more problems, even the sound works… I didn't have to "disable SSD as a cache from Windows". But I can't use 8 GB of the disk (32-8=24GB allowed, not just 8). For the sound, let me time to found the answer again… –  NicoGuich May 11 '13 at 14:35
    
Which version are you using ? I reverted the modification I did with 12.10 to get the sound working, and it's still working with 13.04. (I added "options snd-hda-intel model=ref" in "/etc/modprobe.d/alsa-base.conf".) –  NicoGuich May 11 '13 at 14:45
    
I'm using 12.10 with kernel 3.8 in Legacy mode. –  Étienne Bersac May 28 '13 at 16:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.