Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a new laptop Toshiba Satelite C850-P5010.After installing Ubuntu 12.10,failed to connect to Internet using an external modem.

I connected the modem (beetel 110TC1) to the LAN port the PC led indicator just went off. (no connectivity problem on Windows 7).The network icon on the top panal shows no network connection.

sysinfo displays the Network controller as:

Realtek Semiconductor Co., Ltd.Device8723 and Subsystem: 'Realtek Semiconductor Co., Ltd.Device 0723

Ethernet controller:

Atheros Communications Device 1090(rev 10) and Subsystem: Toshiba America Info Systems Device ff1e

When I ran lspci in a terminal the result displayed was:

01:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 10)  
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8723  

I tried the solution given for " Installing Driver for AR8161 on an offline machine", but failed. How can I install Driver for AR8162 on my LAP?

share|improve this question
    
Can anyboy help me? –  Saji Francis Dec 10 '12 at 18:18
    
How can I install Driver for AR8162 on my LAP ? –  Saji Francis Dec 11 '12 at 17:19
    
Have you tried using the unofficial drivers as explained here ? –  galath Jan 15 '13 at 18:54
add comment

1 Answer

Go to http://www.buzzard.me.uk/toshiba/download.html by using another computer and download Thoshiba linux Utilities version 2.0.1 source. Then copy the driver into desktop & extract. Double click on install.sh file or run in terminal. Restart & connect net or try attach a usb modem (Huweai E303 D / E1762- with idea 3g-INDIA- working) to connect net. Then update the kernel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.