Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I fire up remote desktop on Windows and connect to my server (Windows Server 2008), the fonts look pretty smooth. I just installed Ubuntu 10.10 yesterday and when I use rdesktop to connect the fonts look terrible.

I've looked at all the settings but had no luck. Maybe there's some secret switch, or do I need to use a different client?

share|improve this question
    
hmmm... looking at terminal services client, it only supports RDP 5.0. ClearType was added in RDP 6.0, looks like I might need a different client. –  Andy E Jan 20 '11 at 10:35
add comment

4 Answers

up vote 1 down vote accepted

You can try to look at http://katastrophos.net/andre/blog/2008/03/10/rdesktop-connect-to-windows-vista-with-cleartype-font-smoothing-enabled/

Fonts will be better

share|improve this answer
    
+1 and the green tick — excellent find, thanks! –  Andy E May 22 '11 at 18:28
add comment

My guess is that you want to check out remmina (http://remmina.sourceforge.net/) which has quality options for RDP 5. I'm not aware that there's an RDP 6 client for us for the time being.

share|improve this answer
    
Thanks for your answer. Unfortunately RDP 5 doesn't support ClearType. I looked at Remmina and it's based on FreeRDP, which is a fork of rdesktop. Both only support upto RDP 5. –  Andy E Jan 20 '11 at 15:21
add comment

Perhaps not completely helpful, since Wishi has already suggested it, but for the record, there's no reason that Remmina should be displaying "terrible" fonts. You won't get Cleartype, sure, but they should still be slick and readable.

Here's a screenshot from my Windows 2003 box :

Remmina RDP Client

That's running 16-bit colour, though. In order to try that, go to the settings page in Remmina and change it from 256 colours to 16-bit :

Remmina Settings Page

share|improve this answer
add comment

use the latest freerdp and give it the parameter -x 80 , this is the user experience flag which enables everthing that freerdp supports so it should be identical to being directly on the box. (or at least it is for windows7)

these flags are documented by microsoft here: http://msdn.microsoft.com/en-us/library/cc240476

i still have to enable font smoothing each time i reconnect to my windows 7 box and haven't found a way round that yet.

edit: xfreerdp flags kan be read here http://linux.die.net/man/1/xfreerdp

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.