Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I apologise if I sound at all dumb. This is my first dedicated server having used a VPS for over a year and I'm trying to setup a VPS on this new server. I purchased a subnet from my hosting provider that I believe allows me 6 usable IP addresses:

177.xx.xxx.201 - 177.xx.xxx.206

The subnet address looks like this: 177.xx.xxx.200/29. I've gone on my server and added them like it said on a wiki like so:

ip addr add 177.**.***.201/29 dev eth0

I done that for all six and now when I go to them in the browser they point to my server. The problem is, I'm using OpenVZ web panel to create VMs (http://code.google.com/p/ovz-web-panel/) so I created a VM and assigned one of those IPs to it. However when SSHing to that IP it SSH's to the dedicated server and not the VM. Am I missing something?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

OpenVZ is adding a new vmnet0 interface.

If those address are routed to your server IP address as a subnet You just have to enable routing in kernel.

If those address are on the same subnet as your server IP You have to create a bridge of this interfaces (venet0 and eth0).

I wrote that in polish but commands are the same :)

http://www.dobreprogramy.pl/okokok/How-To-Serwer-VPSow-na-OpenVZ-i-SolusVM-w-VMWare-Workstation-cz,37584.html

edit: Those address are in the same subnet as eth0. Don't add those address to eth0. Just create a bridge of eth0 and venet0.

edit2: Sorry, commands in my article are for CentOS :(

It's for Debian and Ubuntu: http://wiki.debian.org/NetworkConfiguration

You would have to install bridge-utils.

share|improve this answer
    
Hmm they are on a different subnet to the host server. But I have solved it. I had to go into /etc/network/interfaces and change the IP –  andy Nov 30 '12 at 16:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.