Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new Toshiba qosmio x870 and for the past one week I have been trying to install Ubuntu 12.04 from a USB and Live CD without success. I keep on getting this error:

Boot failure: a proper digital signature was not found. One or more files on the selected boot device was rejected by the Secure Boot feature.

I even tried installing Ubuntu with the Windows installer. After installation and I reboot the PC, first I see the error that points to:

\ubuntu\winboot\wubildr.mbr
Status: 0xc000007b
Info: The OS couldn't be loaded because a required file is missing or contains errors.

When I restart, that the previous error doesn't show up and I see both Windows 8 and Ubuntu (happy that I was successful) but when I click on Ubuntu, it flags an error. This is the first time I'm having a Secure Boot-capable PC. What will be the danger in disabling the secure boot? I'll be happy if I can get assistance from anyone.

share|improve this question

2 Answers 2

up vote 2 down vote accepted
  1. First install Ubuntu-Secure-Remix-64bit (or Ubuntu12.10 64bit) then use Boot-Repair's Recommended Repair as described in the first paragraph of https://help.ubuntu.com/community/UEFI

  2. If that fails, disable SecureBoot in your firmware as described here: https://help.ubuntu.com/community/UEFI#SecureBoot , and run Boot-Repair again.

share|improve this answer
    
Thanks! I had to disable it before I was able to run the suggested kernel. That is solved. My other problem is that I can't see my home wireless and the LAN isn't connecting. This works on Windows 8 from the same PC. –  Mighty Dec 4 '12 at 15:53
    
Glad it worked! please don't forget to validate my answer. Then please create another question for your other problem. –  LovinBuntu Dec 5 '12 at 21:55
    
Thanks again. Please I'm new to the forum. How do I validate this post? –  Mighty Dec 5 '12 at 23:56
    
i think you just need to click on the UP arrow at the left-side of my answer. –  LovinBuntu Dec 6 '12 at 9:43
    
Vote Up requires 15 reputation. Anyway, I have edited the topic as SOLVED. Thanks! –  Mighty Dec 6 '12 at 12:52

You have three options:

  1. Disable Secure Boot. This is likely to be the easiest solution if you want an LTS version of Ubuntu. The downside is that you'll lose the benefits of Secure Boot in protecting against malware. Note that losing Secure Boot is no worse than running Windows on a BIOS-based computer, but in theory at least, Secure Boot can provide some benefits. Also, there's no standardization in user interfaces, so it's impossible to provide detailed instructions on how to do this that apply to all computers.
  2. Try Ubuntu 12.10, which ships with an EFI boot loader configuration that should work on Secure Boot systems that support Microsoft's standard keys. This is a brand-new feature with 12.10, which is why it's not working for you with 12.04. The fact that it's so new means that it's not yet been well-tested, though.
  3. Create your own Secure Boot keys, add them to your firmware, and sign both your Ubuntu boot loader (GRUB 2, by default) and the Windows boot loader with your keys. This will take a fair amount of effort and will require ongoing effort whenever a boot loader is updated, but it gives you total control of the Secure Boot environment -- if and when malware signed with Microsoft's key starts making the rounds, your system won't run it.

I've written a Web page that covers all three options in more detail.

share|improve this answer
    
Thanks a lot. I took the easier step 1 in disabling secure boot. Without disabling the secure boot, I couldn't access both Ubuntu 12.04.1 and 12.10. Now on both kernel, both wireless and LAN isn't accessible from the LIVE usb. I was able to Try Ubuntu but couldn't connect to the internet. When I click on the wireless button on the keyboard, I notice it turns on and off but doesn't see my home internet. Should I go ahead and install? I'm afraid I might not be able to access internet after installation. Thanks for your assistance. –  Mighty Dec 4 '12 at 14:39
    
I recommend asking on a forum for help in debugging the network connectivity issue. Chances are you need to add a new driver or two, but there could be another issue. In a worst-case scenario, you might need to buy a USB network interface. If the network doesn't work from the installation disc in "try before installing" mode, chances are it won't work when fully installed, so if the computer is your only means of Internet access, leave Windows installed, at least at first, so you can reboot into Windows to get on the Internet and debug problems. –  Rod Smith Dec 4 '12 at 22:28
    
Thanks a lot for your suggestion. –  Mighty Dec 5 '12 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.