Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When my computer starts up, it goes to a purple screen. I can go to the Ubuntu side just fine, but when I choose Windows 7 it says:

error: invalid EFI file path.
press any key to continue...

So what is wrong?

yes, the boot repair worked, thank you!

share|improve this question
    
Did it work recently? If yes - what have you changed? If no - have you installed a new system? Have you installed ubuntu after Windows? Do you have different paritions for your installations? The Windows 7 EFI is the windows 7 system partition. It seems grub2 is unable to find this partition (Usually a 100 MB partition labeld as system partition). So basically .... tell us more details about your system –  Grrbrr404 Nov 30 '12 at 11:12
add comment

1 Answer 1

Obviously you need to repair your EFI booting.
It can be happens if:
1. Was reinstalled system.
2. Your UEFI partition was broken, formatted, or erratic cleaned.

Exist nice solution for this:

Open your terminal and type:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

Press Enter key, and wait for completion. Then type:

sudo apt-get install -y boot-repair && boot-repair

Again press Enter key, wait for install completion and program running.

For next steps refer to this links:

Ubuntu Documentation - Boot-Repair
Boot-Repair project

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.