Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed the Turkish, Bulgarian and French language packs from Systems Setting->Language Support and pressed the Apply button. I have even restarted the system several times but no success. I can't see the installed languages. Only the ones installed by default are still visible there. Can anyone help me?

Many thanks!

share|improve this question

2 Answers 2

Perhaps, it was only installed languages but not keyboard layouts.
Try to check: System Settings > Keyboard Layout

Type of input can affect desktop controls.
In between, IBus support should be enabled to fix language indicator issues.
Read more about Community Help Wiki - IBus

Look for this nice help about IBus: How to Enable Foreign Language Input In Ubuntu

Also check your Keyboard Layout > Layouts tab > Options > Key(s) to change layout.

share|improve this answer
    
Thanks so much for the answer but it's not working. My aim is to change the system language different from English. I have no problem with the keyboard. I can type in many languages but I can't change the language for the menu and the regional language. –  user108610 Nov 30 '12 at 12:36
    
Updated, check IBus, and go on! :) –  swift Nov 30 '12 at 13:00

Once you have language support open, you need to drag the language you want up to the top of the list. I found this confusing at first since the other languages are gray. But they are not "grayed out". You can still drag them up. Also the languages you installed will be at the bottom of the list and scrolled of the visible portion of the list box. I had also thought they were not installed.

Drag the one you want to the top of the list and click "Apply system wide". On the Regional Formats tab, choose the language you want (here it's a pop-up list and easier to use) and again click Apply system wide.

If you plan to use switch between all three languages frequently, you might want to take a different approach. Changing from, say, Turkish to French will cause the system to want to change the names of your home folders. A slow-down at best but a possible a source of problems later.

My recommendation is to make 3 new users, one for each language. user-turkish, user-french, etc. When you create the user, set the language to the one you want. This will have the same effect of changing the language/regional settings but for that user only. After that you can edit permissions on the home folders to make sure you can use all of your files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.