Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've upgraded Lubuntu 12.04 to 12.10 via the update manager. Now when Lubuntu is loaded, the cpu usage drops to 0% for a few seconds then shoots up to 100% where it stays for 15 or 20 minutes. I downloaded the iso and did a full re-install but it still occurred. The same thing happens when running Lubuntu 12.10 from the install disk. I threw in the 12.04 disk and everything was fine so it seems to be a 12.10 problem .

Task manager shows cpu at 100% on the bar graph but negligable cpu usage in the list. Running top in terminal shows the same, ie very little cpu usage except wa(i/o wait) which stays in the high 90's. If I run a program, wa drops but shoots up again after the program loads so this isn't really affecting the computers performance but I'd still like to know what the cause of it is.

Also, logging out and back in after the cpu usage has come down restarts the problem.

System information: Northwood pentium 4 2.6ghz 533 on a microstar ms6533e mobo, 1gb ddr266 ram, 80gb pata HDD

Output from top -n1 | head -n15

top - 09:03:05 up 6 min,  2 users,  load average: 1.05, 0.94, 0.47
Tasks: 118 total,   1 running, 117 sleeping,   0 stopped,   0 zombie
%Cpu(s):  8.5 us,  3.6 sy,  0.6 ni,  2.8 id, 84.4 wa,  0.0 hi,  0.1 si,  0.0 st
KiB Mem:   1027016 total,   411788 used,   615228 free,    39092 buffers
KiB Swap:  1048572 total,        0 used,  1048572 free,   235008 cached

  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND           
 1751 peter     20   0  5452 1284  972 R   6.3  0.1   0:00.01 top               
    1 root      20   0  3596 1924 1244 S   0.0  0.2   0:00.96 init              
    2 root      20   0     0    0    0 S   0.0  0.0   0:00.00 kthreadd          
    3 root      20   0     0    0    0 S   0.0  0.0   0:00.07 ksoftirqd/0       
    4 root      20   0     0    0    0 S   0.0  0.0   0:00.20 kworker/0:0       
    5 root      20   0     0    0    0 S   0.0  0.0   0:01.13 kworker/u:0       
    6 root      rt   0     0    0    0 S   0.0  0.0   0:00.00 migration/0       
    7 root      rt   0     0    0    0 S   0.0  0.0   0:00.00 watchdog/0   
share|improve this question
2  
Type top -n1 | head -n15 at the $-prompt then add the output to your question. –  jippie Nov 30 '12 at 8:07
    
High waitio means the system is waiting for data from your disk. Probably an updatedb is running. The various desktops that implement some sort of file search funtionality start indexing. –  jippie Nov 30 '12 at 8:09
add comment

1 Answer

I seem to have solved this problem. It was hardware related after all. After installing iotop and running command

<iotop -o>

the output under IO was: 99.99% mount /media/floppy.

As I had removed the floppy drive some time ago it was never going to find it. The answer was to go into bios and select "none" under floppy drives. Cpu usage is now back to normal after lubuntu loads. For some reason 12.04 didn't have a problem with the previous settings.

Thanks to jippie for pointing me in the right direction.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.