Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have a Tomcat server which is working fine with applications like Jenkins. I'm trying to load my application which tried to create a H2 database on ~/Xinco/data which translates to /usr/share/tomcat7/ at runtime.

I got this error:

javax.persistence.PersistenceException: Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.4.0.v20120608-r11652): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Error while creating file "/usr/share/tomcat7/Xinco" [90062-168])

I went ahead and created the Xinco/data folder but it still fails creating other database related files.

I'm sure is something on the permissions for the Tomcat user.

Any hints?

share|improve this question
I'm pretty sure /usr/share/tomcat7 is not a correct place for any database files: "The /usr/share hierarchy is for all read-only architecture independent data files." ( – Sergey Nov 30 '12 at 1:41
I just defined it using ~, which should be a better place? – javydreamercsw Nov 30 '12 at 17:20
Have you solved your problem? – user256646 Apr 11 '14 at 11:19
Not yet. Migrated to OpenSuse and haven't tried it yet. – javydreamercsw Apr 11 '14 at 15:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.