Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After using the GNOME3 PPA to upgrade Nautilus , (I have been working with it for several days without problems), the Global Menu broke for all Gnome-application, like totem, gnome-terminaL, nautilus 3.4, etc...). At the same time, when I launch any of these applications from terminal, I get the following error:

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:62:17: Theming engine 'unico' not found

I purged the GNOME3 PPA, re-updated, auto-cleaned, dist-upgraded, downgraded Nautilus, reinstalled the gtk3-engines-unico and appmenu, but in vain.

enter image description here

Anyone has a clue of fixing this?

~$ apt-cache policy gtk3-engines-unico
gtk3-engines-unico:
  Installed: 1.0.2+r139-0ubuntu2
  Candidate: 1.0.2+r139-0ubuntu2
  Version table:
 *** 1.0.2+r139-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

~$ apt-show-versions gtk3-engines-unico
gtk3-engines-unico/quantal uptodate 1.0.2+r139-0ubuntu2

The Unico issue seems to be known in RR.13.04.

I have Installed gtk3-engines-unico from RR-13.04, to see if it fixes the issue but in vain. Now I get a different error message when running a Gnome application from Terminal:

Failed to load type module: (null)

menu_proxy_module_load': /usr/bin/python:
undefined symbol: menu_proxy_module_load

But what about 12.10?

share|improve this question
    
Probably happening because gtk3-engines-unico is either out of date or too new. –  MiJyn Nov 29 '12 at 23:46
    
I have the version which is in the archive. It's not outdated. –  Hanynowsky Nov 30 '12 at 0:07
1  
Ok, then yes it is :). That is because the rest of GNOME is updated to a newer version (via the GNOME 3 PPA), but gtk3-engines-unico isn't. You see what I mean? –  MiJyn Nov 30 '12 at 0:11
    
I see. I already purged the GNOME3 PPA. but that did not help. I updated, checked if these Gnome Apps like totem or Gedit are newer than those in Quantal archive and it seems, not. –  Hanynowsky Nov 30 '12 at 0:14
    
Try running the system upgrades (sudo apt-get dist-upgrade) –  MiJyn Nov 30 '12 at 0:18

1 Answer 1

Ok. Solved the problem.

The problem came from libgtk-3-0. A newer version (3.6.2) than the one in quantal archive ( 3.6.0-0ubuntu3.2 ) was still kept in the system.

Actually, the GNOME3 PPA purging when I first did it, was not performed correctly due to a bug in the ppa-purge package in quantal official archives (multi arch bug). So I :

  • installed a new version of ppa-purge which fixed the bug.
  • re-added the GNOME3 PPA again : sudo apt-add-repository ppa:gnome3-team/gnome3.
  • ran ppa-purge again : sudo ppa-purge ppa:gnome3-team/gnome3

It downgraded all the packages installed from GNOME3 PPA to the ones from the official quantal archives.

  • A logout was necessary for changes to take effect.
share|improve this answer
    
There was an issue with the GTK package in the GNOME 3 PPA but it was fixed... Now the global menu should work. –  Alin Andrei Dec 2 '12 at 18:04
    
@AlinAndrei Thanks for pointing this out. I'd retry with with the PPA again. –  Hanynowsky Dec 4 '12 at 3:56
    
I can confirm that it's been fixed. –  William Jan 6 '13 at 20:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.