Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Cannot boot to Ubuntu, though installation was successful

Actually the question says it all, but let me tell you what I did, so u may find exactly what might have went wrong:

I have Win 8 installed on 500 GB HDD.

SO I shrunk it four times for:

partition 1 - the original partition containing Win 8 sys (118GB)

partition 2 - NTFS formatted for my data (188GB)

partition 3 - NTFS formatted for my data (100GB)

partition 4 - NTFS formatted for Linux distro say Ubuntu (I reformatted it to ext4 during Ubuntu installation) (25GB)

partition 5 - NTFS formatted for Linux distro (am thinking to try Mint in it) (21GB)

So now I booted Ubuntu from USB (created from ubuntu-12.04-desktop-amd64.iso) and deleted last two partitions 4 and 5 to create:

partition 1 - ext4 where I installed Ubuntu (25GB)

partition 2 - Swap (4GB)

partition 3 - unallocated space, not formatted yet (17GB)

Ubuntu installation said it installed successfully and that I have to restart to boot in Ubuntu. But when I restart Windows 8 auto booted - there was no dual boot.

After that I devided above 100GB partition to 80Gb and 20GB ones (since I read online that I should have /home in separate partition for convenience, so I created 20GB partition for it)

So I went on to manually create boot entry using EasyBCD as below show in picture at below link

enter image description here

When I created the entry, FreeBCD showed the information as follows:

Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=\Device\HarddiskVolume2
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
integrityservices       Enable
default                 {ea8167ad-d189-11e1-90e4-ab2f09569dcc}
resumeobject            {ea8167a3-d189-11e1-90e4-ab2f09569dcc}
displayorder            {ea8167ad-d189-11e1-90e4-ab2f09569dcc}
                        {ea8167b1-d189-11e1-90e4-ab2f09569dcc}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 10
displaybootmenu         Yes

Windows Boot Loader
-------------------
identifier              {ea8167ad-d189-11e1-90e4-ab2f09569dcc}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 8
locale                  en-US
osdevice                partition=C:
systemroot              \Windows
resumeobject            {9bc7fdf7-3ae0-11e2-be77-806e6f6e6963}

Real-mode Boot Sector
---------------------
identifier              {ea8167b1-d189-11e1-90e4-ab2f09569dcc}
device                  partition=C:
path                    \NST\AutoNeoGrub0.mbr
description             Ubuntu

Notice the last bolded entry created.

Howevever after thet, when I rebooted it firstly showed old DOS like bootloader (no Windows 8 UI based bootloader) with two entries Windows and Ubuntu.

Windows 8 was booting correctly but I was getting an error while booting Ubuntu taking me to GRUB Rescue.

Update:

Now, I rebuilt Windows bootloader from Windows disk with command bootrec /rebuildbcd. So currently there is no dual boot menu. It loads Windows. Then I booted Ubuntu from Live USB and tried to install GRUB, but it said command not found, so I tried to set path as follows but it did not worked.

This occcured:

ubuntu@ubuntu:~$ sudo grub 
sudo: grub: command not found ubuntu@ubuntu:~$ 
sudo /sbin/grub 
sudo: /sbin/grub: command not found

Is it like that during installation only Ubuntu was installed on the partition but no GRUB were installed. That may be the reason for the failure of auto GRUB bootloader entry (last entry) created by FreeBCD since it is not able to find GRUB in any partition. This may be the reason for failure of sudo grub.

So what should I do next? Please help am new to Linux world.

share|improve this question

marked as duplicate by Luis Alvarado, Ringtail, Jorge Castro, fossfreedom Dec 1 '12 at 10:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I gotta say "Mother of god!". Since I can't give you a clear answer I recommend first to boot from the Live USB you made. From there run gparted and remove all partitions related to Ubuntu. Then do any cleanup needed for an other partition that you want to change in Windows (If you have to). After that reboot and run the LiveUSB again. But before doing all of this, we really need to know what kind of hardware do you have. What motherboard, cpu, memory, etc.. This might help somehow. –  Luis Alvarado Nov 29 '12 at 23:06
    
@LuisAlvarado-TheWolverine I think that he should install GRUB from the LiveCD and done. It has worked for me. –  Lucio Nov 29 '12 at 23:23
    
@lucio - Yes, that would be the first thing to suggest, but since he did a couple of things to the disk I wouldn't know what to say right now. But your suggestion is a good one. –  Luis Alvarado Nov 29 '12 at 23:34
    
@LuisAlvarado-TheWolverine @Lucio First I note that I rebuilt Windows bootloader from Windows disk with command bootrec /rebuildbcd. It worked and Windows is able to boot. Then I booted Ubuntu from Live USB and tried to install GRUB, but it said command not found, so I tried to set path as follows but it did not worked. This occcured: ubuntu@ubuntu:~$ sudo grub sudo: grub: command not found ubuntu@ubuntu:~$ sudo /sbin/grub sudo: /sbin/grub: command not found –  Mahesha999 Nov 30 '12 at 6:54
1  
@LuisAlvarado-TheWolverine I think that this post should be marked as a duplicated of this one. Don't you think so? –  Lucio Nov 30 '12 at 15:43
show 5 more comments

2 Answers 2

up vote 1 down vote accepted

Solved this by using Boot-Repair explained here

share|improve this answer
add comment

This happened to me also (the issue with auto-booting into Windows) - I fixed it by disabling Hybrid Boot.

Being Windows 8, the steps for doing this are not massivly intuitive, but anyway:

1) Open Windows Explorer (file browser) on your desktop taskbar

2) Click in the location bar and type "Control Panel" and hit Enter

3) Type "Power" into the search box and click "Power Options"

4) Click "Choose what closing the lid does" on the left pane

5) Find "Turn on fast startup (recommended)" and turn it off

6) Save changes and reboot

This worked for me - though I installed Ubuntu 'after' doing this so I don't know if you need to re-install GRUB or not. You shouldn't need to, I don't think, but comment on this if your laptop still won't load Ubuntu and I'll try to help you further :)

share|improve this answer
    
that did not worked for me, please read question I updated at the end –  Mahesha999 Nov 30 '12 at 7:25
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.