Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hey guys I'm having trouble setting up Ubuntu Bonding, following this guide.

My interfaces file looks like this:

auto eth0  
iface eth0 inet manual  
bond-master bond0  

auto eth1  
iface eth1 inet manual  
bond-master bond0  

auto bond0  
auto iface inet static  
bond-mode balance-rr  
bond-miimon 100  
bond-lacp-rate 1  
bond-slaves none

I can ping Google and my external static IP from another computer on another ISP (I assigned it a static one-to-one NAT address with the router and also disabled the router's firewall for troubleshooting). However, from the Ubuntu machine, I can't ping it's gateway (even though it uses it to get to Google lol) and I can't ping any other internal address.

If I comment out the bonding and only use eth0 or eth1 everything works just fine. Any thoughts?

share|improve this question

You have an error in this line:

auto bond0
auto iface inet static

It should be:

auto bond0
iface inet static
share|improve this answer

Version 13.04 includes network bonding. Very easy to use and you can select each real network connection that will be part of the virtual (bond) network.

enter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.