Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i right click to bring up a menu, for example on the desktop, i have 'open terminal here' which i know should have a terminal icon next to this however it doesn't. Any ideas? I had a poke around in gconf-editor but didn't have much luck (though i didn't try very hard ;)

Thanks

share|improve this question
    
What flavor of Ubuntu are you using? –  Marco Ceppi Aug 14 '10 at 0:45

2 Answers 2

up vote 5 down vote accepted

In gconf-editor go to desktop -> gnome -> interface and check the checkbox for menus_have_icons. There's also a buttons_have_icons which you may want to enable.

This was a delibrate 'feature' in Gnome 2.28, from which Ubuntu 10.04 for built.

These two options can also be changed through the "Gnome settings" panel of Ubuntu Tweak, see screenshot below. (Ubuntu Tweak can be installed through a PPA) Ubuntu Tweak - Gnome Settings Panel

share|improve this answer
    
Thanks for the informative answer, the gconf settings worked perfectly! –  Will Aug 14 '10 at 9:26

fluteflute's answer is excellent, but in case anyone wanted to change this setting without using Ubuntu Tweak, you can do this by changing the following two gconf settings to true using gconf-editor (a GUI program) or gconftool (a command line program):

gconftool --set /desktop/gnome/interface/menus_has_icons --type bool true
gconftool --set /desktop/gnome/interface/buttons_have_icons --type bool true
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.