Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Background: I'm trying to set up my dad's new installation of Xubuntu 12.10 (I finally got him to switch from Windows :-D) so he can sync his Palm Centro on his computer. I installed J-Pilot, but the problem is that his palm isn't even showing up anywhere on the computer. When it's plugged in, it lit up and began to charge when I told it to try and sync with the computer, but it failed the sync and Xubuntu still doesn't recognize it.

Question: Does anyone know how I can get his Palm to be recognized by Xubuntu?

share|improve this question
Thx a lot! This has worked-around my .jpilot Palm m505 Handheld synchronization issues on Trusty Tahr Ubuntu 14.04 LTS as of August 2014: jpilot run as root is working fine. You can synchronize Palm / Visor / Treo / Clie with that. Now finding running it as user again... – user317988 Aug 18 '14 at 14:46
up vote 1 down vote accepted

The Palm USB connection works only during a hotsync operation.

So if you installed Jpilot, try clicking both the hotsync button on your Centro and on Jpilot.

If this doesn't sync, open a terminal and type sudo usermod -a -G dialout username changing username with your actual username.

Then try syncing again as explained above.

share|improve this answer
Will that overwrite what's on the Palm? – DaimyoKirby Nov 30 '12 at 13:17
No it won't overwrite anything. It should copy the address book, datebook etc to jpilot. – To Do Nov 30 '12 at 15:57
That didn't work, although I stumbled on the correct answer. It seems that you don't need to be a part of the dialout group - to test, I created a new user, and tried to sync under sudo, and it started to sync, despite the new user not being a member of the dialout group. Thanks for responding, anyway! – DaimyoKirby Dec 3 '12 at 5:14
Being able to sync as your normal user without using sudo requires being in the dialout group. I don't think it is a good idea to use jpilot always with sudo. It's an old application which is no longer supported. – To Do Dec 3 '12 at 7:52
Oh, yeah, that worked. I had added myself to the dialout group using your command earlier, it just hadn't worked the first time; maybe I was just too tired to think clearly... Thanks so much for helping! – DaimyoKirby Dec 7 '12 at 4:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.