Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using dual boot with Windows 8 and Ubuntu 12.04. When I use Windows 8, everything works perfectly but when I use Ubuntu 12.04 my CPU heats up too quickly.

Why does it happen only in Ubuntu and not in windows and what can I do to prevent it.

Thanks!

My computer: HP ProBook 4540s

share|improve this question
    
Many friends of mine have the same issue. I guess Ubuntu doesn't have a power management system like windows does, –  Shagun Nov 29 '12 at 13:09
2  
It does and its actually part of the kernel for a long time. Mostly these are issues caused by the graphics GPU and not the CPU and that is managed by the display driver in use. –  Bruno Pereira Nov 29 '12 at 13:37
1  
Can you feel the heat or is it just the fans are on? I ask because I have a Probook 4510s and it's fan are always on full after I wake the computer from sleep, it's a known bug and has been around for ages. theres a bug report here bugs.launchpad.net/ubuntu/+source/linux-source-2.6.17/+bug/… –  Shutupsquare Dec 23 '12 at 13:08
    
is there any way so i can switch between graphics cards like i can tell in Windows on what application I need AMD Radeon HD and on what i dont ? –  Rana Muhammad Waqas Mar 19 at 4:48

3 Answers 3

Install your display driver....

I have the same laptop with AMD Radeon HD 7650M 1GB VGA. Go to the System Settings> Additional Drivers, and install the graphics diver, if you are using AMD hardware like me.

This should work also if you have a Nvidia card.

share|improve this answer
1  
Indeed there is a driver, but when I install it I won't be able to use GNOME3 full \ Unity 3D.. –  Billie Dec 1 '12 at 19:06
    
I have instlled the drivers and still i am having the problem of over heating. From where I switch between graphics cards ? –  Rana Muhammad Waqas Mar 19 at 4:45

Turning off switchable graphics in BIOS should make your laptop run cooler and double the battery life.

share|improve this answer
1  
how can one turn off switchable graphics from BIOS? what are the steps? –  Hafiz May 23 '13 at 21:34
1  
There is an option in "Integrated Hardware" > Discrete Video Card –  Gtx Mar 6 at 13:39

It's not just the CPU, the main cause it's the GPU, because this laptop has a integrated intel HD graphics 4000 if i'm not mistaken and the dedicated one radeon 7XXX HD depending on model. The thing is, when running on Windows 8 ,or Windows in general , it happens that in low - medium demanding processes, it runs on the integrated one, which is not weak at all, but it runs on it for generating less heat to the whole system. When running higher demanding processes such as top notch games, it switch to the more powerful one , the Radeon. The thing is that on Ubuntu, this doesn't happen. BOTH of the GPU's are running, overall generating more heat to the whole machine. This is the cause for overheating on ubuntu, as i'm not a master ubuntu user, i don't know exact coordonation for solving the problem, but this is what happens, i hope i cleared the situation for you a bit. Cheers !

share|improve this answer
    
This doesn't seem to be an answer. You could summarize and add it as a comment. –  edwin Jul 25 '13 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.