Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when doing sudo apt-get install python-scipy on an Ubuntu 12.10 machine, I get this:

Reading package lists... Done

Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-scipy : Depends: python-numpy (>= 1:1.6.1) but it is not going to be installed
                Depends: python-numpy-abi9
                Depends: libgfortran3 (>= 4.6) but it is not going to be installed
                Depends: liblapack3 but it is not going to be installed or
                         liblapack.so.3 or
                         libatlas3-base but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Do you have any idea on how to solve this?


share|improve this question

1 Answer 1

well I got scipy installed so it's definitely possible. ;-)

I think you have some hiccup in your package system - any problems lately such as crashed or aborted installations? alternatively, it's some dependency problem.

anyway, whenever I encounter this, first I try to install the "unmet dependencies" manually, one after the other, so you can try to install python-numpy, then libgfortran3, then liblapack3, and then try again. a sudo apt-get update before all that can't be wrong, either.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.