Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed XVidcap from synaptic. There is an option in preferences to turn on audio recording but there is no audio in final output. I followed instructions on Ubuntu Forums and downgraded the package to an older version but still can't get it working.

share|improve this question

7 Answers 7

up vote 5 down vote accepted

I've got the solution in this blog post:

  1. Uninstall xvidcap in Synaptic
  2. Install xvidcap from http://sourceforge.net/projects/xvidcap/files/xvidcap/1.1.7/xvidcap_1.1.7jaunty_i386.deb/download
  3. Lock the installed version in Synaptic
  4. Install pavucontrol in Synaptic (Needed in Ubuntu 10.04 but not in Linux Mint 10: already present)
  5. Open the program with padsp xvidcap
  6. Click on the recording button (red circle)
  7. Run pavucontrol, go to the Recording tab and there choose Monitor of Analog Stereo Internal Audio

Done!!

To record with sound, the program has always to be run with padsp xvidcap (for example from ALT+F2). To run it always like that from the menu: run alacarte, go to Sound and video, then to XVidCap Screen Capture, Properties and where it says Command put padsp xvidcap.

[ I would add this: ]

The stated is to record the system sound, that is, the one coming out of the speakers, that can be of a song or movie of our hard drive or pendrive played by Totem, of a Flash music video of a website played by Firefox, ...

Nevertheless, sometimes it can be necessary to record the microphone sound, for example if we want to make a videotutorial to explain how a program works. In this case we put xvidcap in recording state, run pavucontrol and in the Recording tab we put Analog Stereo Internal Audio (without "Monitor of" ahead).

If we only want to record sound (without video) we can run from ALT+F2 gnome-sound-recorder. The first time probably it will be configured to record from the microphone. To record the system sound we run with ALT+F2 gnome-volume-control, go to the Hardware tab and in Profile we put Analog Stereo Output (it's also possible to do this running pavucontrol and using the Configuration tab).

But when we finish we have to put again Analog Stereo Duplex in the Profile of Hardware of gnome-volume-control (or of Configuration of pavucontrol), so we can still choose the origin of the sound when recording with xvidcap.

NB: sometimes, to change from Analog Stereo Duplex to Analog Stereo Output it may be necessary to change first to Off, close, open again and then change finally to Analog Stereo Output. The same for the opposite change. If not, the computer may "not notice" that we have applied the change.

Taken from http://ubuntuforums.org/showpost.php?p=10607591

share|improve this answer
    
Great help, thanks –  trideceth12 Jul 5 '12 at 5:44

You need pavucontrol - from here, you can set Xvidcap to record from your internal audio. alt text

To get XVidCap to be detected, you have to:

  • first record a dummy video (I know, an annoying extra step)
  • find XVidCap in pavucontrol, change it to record from the internal audio
  • Stop recording in XVidCap, delete the dummy video
  • Now record as normal
  • You will not need to do this again if you keep your system on hibernate/sleep instead of restarting, but pulseaudio will not remember your settings if you restart your system.

If this doesn't work, try recording the audio in the background with gnome-sound-recorder, and then adding it to your video using Kdenlive, Pitivi, or Openshot.

share|improve this answer
    
pavucontrol is not detecting xvidcap and any recording stream from it. –  user8592 Jan 19 '11 at 21:46
    
k I'll add a little detail I forgot to add. –  RolandiXor Jan 19 '11 at 21:53
    
I already know about the method you mentioned. While this works with recordmydesktop, it doesn't work with xvidcap even after recording 4-5 videos from xvidcap. Did yo get it working on your system?? Pavucontrol detects xvidcap after recording a dummy video on your system? –  user8592 Jan 19 '11 at 22:01
1  
I added a small suggestion that might work for you, even if it is not ideal :/ –  RolandiXor Jan 19 '11 at 22:11
1  
Yep. That seems to be last resort :) –  user8592 Jan 19 '11 at 22:14

For 64 bits: angel-de-vicente.blogspot.com/2011/03/screencasts-with-xvidcap-in-ubuntu-1004.html : In order to install it in my x86_64 system I just have to use the --force-architecture option to the dpkg -i command.

angelv@vaso:~/Desktop$ sudo dpkg --force-architecture -i xvidcap_1.1.7jaunty_i386.deb

But when trying to run it I see that there are some i386 libraries missing. In order to easily install them I use the getlibs script.

angelv@vaso:~/Desktop$ padsp xvidcap xvidcap: error while loading shared libraries: libtheora.so.0: cannot open shared object file: No such file or directory

angelv@vaso:~/Desktop$ getlibs /usr/bin/xvidcap

%%%%%%%%%%%%%

About getlibs: http://ubuntuforums.org/showthread.php?t=474790

share|improve this answer

After a video is recorded xvidcap offers to play it immediately. But if you click on the "Play" button the video is not reproduced.

This problem happens at least in Ubuntu 10.04 because by default it doesn't have installed mplayer, the program that xvidcap uses to play the videos when pressing on the stated button.

There are 2 solutions:

a) Install mplayer from Synaptic. or b) Go to preferences (right clicking on the name of the file, for example test-0000.mpeg, and then cliking on Preferences), then to the Commands tab, and then in the "Multi-Frame Capture Commands"' "Playback Command" replace mplayer with totem and click on OK. Then right click again on the name of the file and click on "Save preferences".

share|improve this answer

I struggled with this on 64bit Ubuntu - The downloads offer only i386 architecture, and I wasn't keen to force the architecture.

It's relatively simple to compile the offered source, and that also works with the padsp wrapper as per Friendien's answer.

Download the xvidcap-1.1.7.tar.gz file from the sourceforge project above.

Extract the file (tar -xzf ) then cd into the folder and run ./configure At this point you may have to install some extra software - I installed glade (for libglade2.0) and libxmu-dev .

Once configure has run, do make

Then sudo make install

Run it (as suggested) with padsp xvidcap and it's all good to go (for me, Ubuntu 11.04 64bit).

share|improve this answer
    
thank you, that helped me. i also didn't want to force the architecture, and this solution worked just fine. if you get an error when running make, edit the src/capture.c file. uncomment the line #include <X11/extensions/shmstr.h> and put #include <X11/extensions/shmproto.h> –  Alp Apr 20 '12 at 15:52

Another option, not to have to change once and again between Analog Stereo Duplex and Analog Stereo Output neither limit the sound source for xvidcap, is to leave Analog Stereo Duplex and use also pavucontrol when we want to change the source of the sound for gnome-sound-recorder. Like the stated for padsp xvidcap, to change where we want to record the sound from, we put gnome-sound-recorder recording, open pavucontrol and in the Recording tab we put the desired option. In this case there is no need to use padsp (xvidcap needs it because it was designed for OSS. What padsp does is to connect OSS with PulseAudio, as shown in http://linux.die.net/man/1/padsp ).

share|improve this answer

You can install Audio Recorder to record audio from the microphone or from the system: https://launchpad.net/~osmoma/+archive/audio-recorder

share|improve this answer
    
Welcome to Ask Ubuntu! While we're glad you want to help, this is an Ubuntu-only site, so while Mint may be a spin-off on Ubuntu, it isn't recommended you put any reference to Mint or other Linux versions in your answers. The link you gave does work with Ubuntu, so I am just editing your answer to fit the guidelines. As a new user we want you to be involved, but still you need to follow the guidelines. Thanks! –  RPi Awesomeness Dec 18 '13 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.