Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I decided to write because I am having difficulty establishing a connection with one of my laptops. which is partitioned. The side that runs Ubuntu 10.04 does not connect with the wireless router. The other side, running Windows XP, connects fine. Two other laptops (running Windows) and two hard wired computers (one Mac and one running Ubuntu 10.04) are working with good speeds.

It was after switching my Internet Service Provider, that I noticed with this one laptop, the connection was not working. It still works on the Windows side and with Qwest, but I want to stop using Qwest and go with my new ISP (Comcast).

Nothing has changed on any of the settings on any computer, including the laptops. We ran an ethernet cable directly to the wireless router from the laptop with an immediate connection running the Linux side of that laptop. That tells me that the wireless router is functioning; well…the other laptops function also showing me that the router is not the issue.

Here again is my network/computer configuration:

One MacIntosh running OS 10.4 connected via ethernet - works fine

Two laptop PCs running windows wireless connections - both connect just fine

One PC running Ubuntu 10.04 connected via ethernet - connecting perfectly

One laptop partitioned, one side running windows - wireless connection works. The other partition running Ubuntu 10.04, does NOT connect wireless, but does connect via ethernet.

This is all running through a netgear wireless router. Everything worked perfectly when our ISP was Qwest(now called Centurylink), but now that we are using Comcast the one partition on the laptop using Ubuntu does not connect. I have tried deleting all of the auto network connections and reconnecting, changing my router security settings from WPA/WPA2 to WEP and back, rebooting the router and modem and other stuff I can't remember. The only thing I haven't tried was trying to connect using terminal.All of the available neighborhood wireless networks show up. Sorry for any redundancy, I just wanted to make sure I got all the info. Any help anyone can give would be appreciated. Thanks!

share|improve this question
Does it work from the laptop that fails if you boot with a liveDVD/CD ? – belacqua Nov 30 '12 at 0:26
Good idea, and I did end up trying to boot from the live CD of 10.04 as well as 9.10 to no avail. Tried installing Wicd and that didn't work and I lost the applet that displays my connection status (wireless and wired) in the process. The only variable that I can figure out is that I switched from Centurylink to Comcast. All other hardware/software is the same. All the other computers on the network connect just fine. – Barry Nov 30 '12 at 5:02
Chipsets and drivers can be the source of wireless problems. Did the switch to comcast include a different wireless router or access point? – belacqua Nov 30 '12 at 23:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.